Subject: Are we missing a dot in initdb's output?

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Wed, 5 Jan 2022 18:48:57 +0000

Hi,

this is more a cosmetic concern, but anyway: running initdb gives this output:

...
creating configuration files ... ok
running bootstrap script ... ok
performing post-bootstrap initialization ... ok
syncing data to disk ... ok

initdb: warning: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
...

Shouldn't there be a "." after "authentication for local connections"? Probably it should be like this:
initdb: warning: Enabling "trust" authentication for local connections.

initdb's output a few lines earlier gives this, which all close with a "dot" and start with upper case:

"The database cluster will be initialized with locale "en_US.UTF-8".
The default database encoding has accordingly been set to "UTF8".
The default text search configuration will be set to "english".

Data page checksums are disabled."

Regards
Daniel

---

From: Tom Lane <[email-masked]>
Date: Wed, 05 Jan 2022 13:56:25 -0500

> Shouldn't there be a "." after "authentication for local connections"?

Meh, I think this is mimicking our coding style for primary vs. detail
messages.

			regards, tom lane