Subject: Question about criteria for adding items to the v19 open items wiki page

From: Chao Li <[email-masked]>
Date: Thu, 23 Apr 2026 12:36:47 +0800

Hi,

Please forgive this probably naive question, as this is the first release cycle I’ve experienced.

I’ve seen people mention putting something on the v19 open items wiki page many times, but I’m not sure what kinds of things are supposed to go there. What should be added there, and are there any criteria for deciding that?

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: Tom Lane <[email-masked]>
Date: Thu, 23 Apr 2026 00:46:12 -0400

> I’ve seen people mention putting something on the v19 open items wiki page many times, but I’m not sure what kinds of things are supposed to go there. What should be added there, and are there any…

If you think that we have a new bug in HEAD that was not there in
previous releases, feel free to add it to the open-items wiki page.
Worst case is that we'll determine it's not an issue and remove
it again; but it's better to check such things than not.

			regards, tom lane

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 22 Apr 2026 21:57:19 -0700

On Wednesday, April 22, 2026, Chao Li <[email-masked]> wrote:
> I’ve seen people mention putting something on the v19 open items wiki page
> many times, but I’m not sure what kinds of things are supposed to go there.
> What should be added there, and are there any criteria for deciding that?
>

Any bugs discovered in newly developed features in v19.  As a practical
matter, ones that seem complicated to resolve make it there since quickly
resolved ones just get fixed.

Bugs that reproduce in v18 or earlier would not be placed there.

It’s a chance to demonstrate personal judgement.  Severity and
committer/author responsiveness are two additional criteria to judge.  It’s
both a simple tracker but also a kind of escalation channel since it gets
RMT members involved.

David J.

---

From: Chao Li <[email-masked]>
Date: Thu, 23 Apr 2026 13:28:23 +0800

> On Apr 23, 2026, at 12:57, David G. Johnston <[email-masked]> wrote:
> 
> Any bugs discovered in newly developed features in v19.  As a practical matter, ones that seem complicated to resolve make it there since quickly resolved ones just get fixed.
> 
> It’s a chance to demonstrate personal judgement.  Severity and committer/author responsiveness are two additional criteria to judge.  It’s both a simple tracker but also a kind of escalation channel since it gets RMT members involved.
> 
> David J.
> 

In the Open Issues section, I see the first item has no owner listed, so I assume we should add new items to the top of the list, and then, once they are confirmed, either an owner will be assigned, or the item will be moved to “Won’t Fix” or removed. Is that right?

Best regards,

---

From: Tom Lane <[email-masked]>
Date: Thu, 23 Apr 2026 01:33:16 -0400

> In the Open Issues section, I see the first item has no owner listed, so I assume we should add new items to the top of the list, and then, once they are confirmed, either an owner will be assigned…

Further down it says "add new items to the bottom".  I agree
that note is poorly placed.

			regards, tom lane

---

From: Chao Li <[email-masked]>
Date: Thu, 23 Apr 2026 13:42:25 +0800

> On Apr 23, 2026, at 13:33, Tom Lane <[email-masked]> wrote:
> 

Ah… I see the note below the open issue list. Got it.

I will add a few items.

Best regards,

---

From: Michael Paquier <[email-masked]>
Date: Thu, 23 Apr 2026 15:45:06 +0900

> I will add a few items.

Cool.  Please also note that the owner of an item should be the
committer of the feature that has introduced the issue.  Mentioning
the exact commit is also the usual habit when listing an item.
--
Michael

---

From: Chao Li <[email-masked]>
Date: Thu, 23 Apr 2026 14:55:16 +0800

> On Apr 23, 2026, at 14:45, Michael Paquier <[email-masked]> wrote:
> 

Oh, I had thought the owner would be the person assigned to handle the issue. So, then when I add an item, I will try to identify the original committer and the relevant commit.

By the way, I have already requested wiki edit privileges and am now waiting for approval.

Best regards,