public inbox for [email protected]
help / color / mirror / Atom feedFrom: Drouvot, Bertrand <[email protected]>
To: Zhijie Hou (Fujitsu) <[email protected]>
To: shveta malik <[email protected]>
Cc: Peter Smith <[email protected]>
Cc: Amit Kapila <[email protected]>
Cc: Hayato Kuroda (Fujitsu) <[email protected]>
Cc: Bharath Rupireddy <[email protected]>
Cc: Peter Eisentraut <[email protected]>
Cc: Bruce Momjian <[email protected]>
Cc: Ashutosh Sharma <[email protected]>
Cc: Andres Freund <[email protected]>
Cc: pgsql-hackers <[email protected]>
Cc: Ajin Cherian <[email protected]>
Cc: Alvaro Herrera <[email protected]>
Subject: Re: Synchronizing slots from primary to standby
Date: Wed, 29 Nov 2023 10:54:45 +0100
Message-ID: <[email protected]> (raw)
In-Reply-To: <OS0PR01MB5716DCFD6CC89C2F243B55939483A@OS0PR01MB5716.jpnprd01.prod.outlook.com>
References: <CAJpy0uC+2agRtF3H=n-hW5JkoPfaZkjPXJr==y3_PRE04dQvhw@mail.gmail.com>
<OS0PR01MB5716CE0729CEB3B5994A954194B3A@OS0PR01MB5716.jpnprd01.prod.outlook.com>
<[email protected]>
<CAJpy0uAT-oGsgmb4dC=dYYRNY7WXEAAWGWU2kL5phLz3Wcdifg@mail.gmail.com>
<CAA4eK1J=-kPHS1eHNBtzOQHZ64j6WSgSYQZ3fH=2vfiwy_48AA@mail.gmail.com>
<CAJpy0uB_y_1akXUWM9WnSdQ-NVWTnHTpmNu6gJQ5tnyuAMTUOg@mail.gmail.com>
<CAHut+Pv-yu71ogj_hRi6cCtmD55bsyw7XTxj1Nq8yVFKpY3NDQ@mail.gmail.com>
<OS0PR01MB571646B8186F6A06404BD50194BDA@OS0PR01MB5716.jpnprd01.prod.outlook.com>
<OS0PR01MB57161C27BCFAF04C2B48B47394BDA@OS0PR01MB5716.jpnprd01.prod.outlook.com>
<[email protected]>
<CAJpy0uDKPK537ZW8CAjDVmSjHtBKCzTUzq=it84SrA0PfoWFCg@mail.gmail.com>
<OS0PR01MB57161938A348977127D56A6694BDA@OS0PR01MB5716.jpnprd01.prod.outlook.com>
<[email protected]>
<OS0PR01MB5716DCFD6CC89C2F243B55939483A@OS0PR01MB5716.jpnprd01.prod.outlook.com>
Hi,
On 11/29/23 6:58 AM, Zhijie Hou (Fujitsu) wrote:
> On Tuesday, November 28, 2023 8:07 PM Drouvot, Bertrand <[email protected]> wrote:
>
> Hi,
>
>> On 11/27/23 9:57 AM, Zhijie Hou (Fujitsu) wrote:
>>> On Monday, November 27, 2023 4:51 PM shveta malik
>> <[email protected]> wrote:
>>>
>>> Here is the updated version(v39_2) which include all the changes made in
>> 0002.
>>> Please use for review, and sorry for the confusion.
>>>
>>
>> Thanks!
>>
>> As far v39_2-0001:
>>
>> "
>> Altering the failover option of the subscription is currently not
>> permitted. However, this restriction may be lifted in future versions.
>> "
>>
>> Should we mention that we can alter the related replication slot?
>
> Will add.
>
>>
>> + <para>
>> + The implementation of failover requires that replication
>> + has successfully finished the initial table synchronization
>> + phase. So even when <literal>failover</literal> is enabled for a
>> + subscription, the internal failover state remains
>> + temporarily <quote>pending</quote> until the initialization
>> phase
>> + completes. See column
>> <structfield>subfailoverstate</structfield>
>> + of <link
>> linkend="catalog-pg-subscription"><structname>pg_subscription</structna
>> me></link>
>> + to know the actual failover state.
>> + </para>
>>
>> I think we have a corner case here. If one alter the replication slot on the
>> primary then "subfailoverstate" is not updated accordingly on the subscriber.
>> Given the 2 remarks above would that make sense to prevent altering a
>> replication slot associated to a subscription?
>
> Thanks for the review!
>
> I think we could not distinguish the user created logical slot or subscriber
> created slot as there is no related info in slot's data.
Yeah that would need extra work.
> And user could change
> the slot on subscription by "alter sub set (slot_name)", so maintaining this info
> would need some efforts.
>
Yes.
> Besides, I think this case overlaps the previous discussed "alter sub set
> (slot_name)" issue[1]. Both the cases are because the slot's failover is
> different from the subscription's failover setting.
Yeah agree.
> I think we could handle
> them similarly that user need to take care of not changing the failover to
> wrong value. Or do you prefer another approach that mentioned in that thread[1]
> ? (always alter the slot at the startup of apply worker).
>
I think I'm fine with documenting the fact that the user should not change the failover
value. But if he does change it (because at the end nothing prevents it to do so) then
I think the meaning of subfailoverstate should still make sense.
One way to achieve this could be to change its meaning? Say rename it to
say subfailovercreationstate (to reflect the fact that it was the state at the creation time)
and change messages like:
"
ALTER SUBSCRIPTION with refresh and copy_data is not allowed when failover is enabled
"
to something like
"
ALTER SUBSCRIPTION with refresh and copy_data is not allowed for subscription created with failover enabled"
"
and change the doc accordingly.
What do you think?
Regards,
--
Bertrand Drouvot
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com
view thread (108+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected]
Subject: Re: Synchronizing slots from primary to standby
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox