Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1av50w-00007O-1F for pgsql-hackers@arkaria.postgresql.org; Tue, 26 Apr 2016 15:35:02 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84_2) (envelope-from ) id 1av50v-00064f-KB for pgsql-hackers@arkaria.postgresql.org; Tue, 26 Apr 2016 15:35:01 +0000 Received: from makus.postgresql.org ([2001:4800:1501:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1av50u-00063o-3p for pgsql-hackers@postgresql.org; Tue, 26 Apr 2016 15:35:00 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1av50r-0007Pz-DG for pgsql-hackers@postgresql.org; Tue, 26 Apr 2016 15:34:58 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id u3QFYnsv008310; Tue, 26 Apr 2016 11:34:49 -0400 From: Tom Lane To: Robert Haas cc: Alvaro Herrera , Magnus Hagander , Bruce Momjian , PostgreSQL-development Subject: Re: Rename max_parallel_degree? In-reply-to: References: <20160426152217.GA548975@alvherre.pgsql> Comments: In-reply-to Robert Haas message dated "Tue, 26 Apr 2016 11:28:57 -0400" Date: Tue, 26 Apr 2016 11:34:49 -0400 Message-ID: <8309.1461684889@sss.pgh.pa.us> X-Pg-Spam-Score: -2.9 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-hackers Precedence: bulk Sender: pgsql-hackers-owner@postgresql.org Robert Haas writes: > On Tue, Apr 26, 2016 at 11:22 AM, Alvaro Herrera > wrote: >> I think the word "degree" is largely seen as a bad idea: it would become >> a somewhat better idea only if we change how it works so that it matches >> what other DBMSs do, but you oppose that. Hence my proposal to get rid >> of that word in the UI. > Well I agree with that up to a point, but I think ALTER TABLE foo SET > (parallelism = 4) is not a model of clarity. "parallelism" or > "parallel" is not obviously an integer quality. I guess we could > s/parallel_degree/parallel_workers/g. I find that terminology less > elegant than "parallel degree", but I can live with it. Shouldn't it be "max_parallel_workers", at least in some contexts? Otherwise, I'd read it as a promise that exactly that many workers will be used. regards, tom lane -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers