Subject: Re: Adding REPACK [concurrently]

From: Alvaro Herrera <[email-masked]>
Date: Tue, 19 May 2026 20:52:13 +0200

On 2026-May-14, Amit Kapila wrote:

> The broader issue is that the entire logical decoding mechanism is
> designed to process cluster-wide transactions. This patch tries to
> bypass that foundational assumption, but only during the initial
> snapshot construction while processing running_xacts record.
> 
> To be clear, I am not against the idea of db-specific snapshots to
> enable concurrent repacks. My concern is simply the time required to
> get the architecture right. In its current state, we need more time to
> carefully consider how this db-specific concept interacts with the
> rest of the logical decoding machinery, which is built for
> cluster-wide records.

Hmm.  So at this point I have to admit that the time I'll have before
beta 1 is going to be very scarce.  You're probably right that it's
better to revert db-specific snapshots in pg19, and try again for 20.
The revert should be a simple patch.

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/

---

From: Amit Kapila <[email-masked]>
Date: Sat, 23 May 2026 08:29:35 -0700

> better to revert db-specific snapshots in pg19, and try again for 20.

Sounds reasonable.

> The revert should be a simple patch.

I also think so.

-- 
With Regards,
Amit Kapila.

---

From: Alvaro Herrera <[email-masked]>
Date: Sun, 24 May 2026 13:29:28 +0200

> > The revert should be a simple patch.

Okay, pushed the revert after seeing it pass CI:
  https://cirrus-ci.com/build/5520722497372160

Thanks!

---

From: Mihail Nikalayeu <[email-masked]>
Date: Wed, 3 Jun 2026 19:27:00 +0200

Hello, everyone!

I think it is a good time to remind we still have a potential deadlock
issue leading to loosing vast amount of REPACK work.

Best soltuion I was able to craft so far is [1].

Best regards,
Mikhail.

P.S.
I'll continue working on the repack stress test suite in the near future.

[1]: https://www.postgresql.org/message-id/flat/CADzfLwXbUWuS6H4uJEFVL1jS1kzsVnuJ%2BzX1%2BtAEhQxBnEiGKw%40mail.gmail.com#99b8fbf05044d1fb82af01de69510c78