public inbox for [email protected]
help / color / mirror / Atom feedFrom: Dagfinn Ilmari Mannsåker <[email protected]>
To: Peter Smith <[email protected]>
Cc: Michael Paquier <[email protected]>
Cc: Tom Lane <[email protected]>
Cc: PostgreSQL Hackers <[email protected]>
Cc: Peter Eisentraut <[email protected]>
Cc: Euler Taveira <[email protected]>
Subject: Re: pg_createsubscriber TAP test wrapping makes command options hard to read.
Date: Mon, 20 Jan 2025 20:42:45 +0000
Message-ID: <[email protected]> (raw)
In-Reply-To: <CAHut+Ptmusd=7SdZ-n0=fu-Y8ut=UaK9nU4Cqk01wxOmio9nkA@mail.gmail.com>
References: <CAHut+PvfaUZQR3rEnj-Dcg_6713Wu4yRdd-yZkkC9NVsARht8A@mail.gmail.com>
<[email protected]>
<CAHut+Ps6Q+i_3xS6H7ybw3-hx9+2QOuneTJwHArxqxFnKX5+4g@mail.gmail.com>
<[email protected]>
<CAHut+PvFGytgJT+K_e2x+uWKuVYCBR3HNaNtPKYEkO3YxAwZvw@mail.gmail.com>
<[email protected]>
<CAHut+PvYsVhF5k-mYHVEFdpijdgkYRtoeWVxdspxio0ePRpkug@mail.gmail.com>
<[email protected]>
<[email protected]>
<CAHut+Ptmusd=7SdZ-n0=fu-Y8ut=UaK9nU4Cqk01wxOmio9nkA@mail.gmail.com>
Hi Peter,
Peter Smith <[email protected]> writes:
> Hi,
>
> In your v4 patch, there is a fragment (below) that replaces a double
> '--verbose' switch with just a single '--verbose'.
>
> As I have only recently learned, the '--verbose'' switch has a
> cumulative effect [1], so the original double '--verbose' was probably
> deliberate so it should be kept that way.
I was going to say that if it were deliberate, I would have expected the
two `--verbose` swithces to be together, but then I noticed that the
--recovery-timeout switch was added later (commit 04c8634c0c4d), rather
haphazardly between them. Still, I would have expected a comment as to
why this command was being invoked extra-verbosely, but I'll restore it
in the next version.
I've Cc-ed both Peter (the committer) and Euler (the author) in case
they have any insight.
> ~~
>
> # Run pg_createsubscriber on node S
> command_ok(
> [
> - 'pg_createsubscriber', '--verbose',
> - '--recovery-timeout', "$PostgreSQL::Test::Utils::timeout_default",
> - '--verbose', '--pgdata',
> - $node_s->data_dir, '--publisher-server',
> - $node_p->connstr($db1), '--socketdir',
> - $node_s->host, '--subscriber-port',
> - $node_s->port, '--publication',
> - 'pub1', '--publication',
> - 'Pub2', '--replication-slot',
> - 'replslot1', '--replication-slot',
> - 'replslot2', '--database',
> - $db1, '--database',
> - $db2
> + 'pg_createsubscriber',
> + '--verbose',
> + '--recovery-timeout' => $PostgreSQL::Test::Utils::timeout_default,
> + '--pgdata' => $node_s->data_dir,
> + '--publisher-server' => $node_p->connstr($db1),
> + '--socketdir' => $node_s->host,
> + '--subscriber-port' => $node_s->port,
> + '--publication' => 'pub1',
> + '--publication' => 'pub2',
> + '--replication-slot' => 'replslot1',
> + '--replication-slot' => 'replslot2',
> + '--database' => $db1,
> + '--database' => $db2,
> ],
> 'run pg_createsubscriber on node S');
>
>
> ======
> [1] https://www.postgresql.org/docs/devel/app-pgcreatesubscriber.html
>
> Kind Regards,
> Peter Smith.
> Fujitsu Australia
view thread (20+ messages)
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected]
Subject: Re: pg_createsubscriber TAP test wrapping makes command options hard to read.
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox