Subject: Re: random() function documentation

From: Dagfinn Ilmari Mannsåker <[email-masked]>
Date: Tue, 12 Apr 2022 16:12:06 +0100

Dean Rasheed <[email-masked]> writes:

> On Mon, 11 Apr 2022 at 20:20, Tom Lane <[email-masked]> wrote:
>>
>> >> How about we just say "uses a linear-feedback shift register algorithm"?
>
> I think it'd be sufficient to just say that it's a deterministic
> pseudorandom number generator. I don't see much value in documenting
> the internal algorithm used.
>
>> > Should we
>> > perhaps also add a warning that the same seed is not guaranteed to
>> > produce the same sequence across different (major?) versions?
>>
>> I wouldn't bother, on the grounds that then we'd need such disclaimers
>> in a whole lot of places.  Others might see it differently though.
>
> Agreed, though I think when the release notes are written, they ought
> to warn that the sequence will change with this release.

WFM on both points.

> Regards,
> Dean

- ilmari

---

From: Tom Lane <[email-masked]>
Date: Tue, 12 Apr 2022 11:22:31 -0400

> WFM on both points.

Sold then, I'll make it so.

			regards, tom lane