public inbox for [email protected]
help / color / mirror / Atom feedFrom: Tom Lane <[email protected]>
To: Andreas Karlsson <[email protected]>
Cc: Chao Li <[email protected]>
Cc: [email protected]
Cc: Jeff Davis <[email protected]>
Subject: Re: Remove redundant assignment in CreateWorkExprContext
Date: Wed, 14 Jan 2026 02:33:20 -0500
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <[email protected]>
<[email protected]>
Andreas Karlsson <[email protected]> writes:
> On 8/21/25 5:47 AM, Chao Li wrote:
>> While discussing [1], I was reading execUtils.c, then I noticed this
>> redundant local variable assignment in CreateWorkExprContext(). The
>> attached patch fixed that.
> Nice spotted but I think your patch reduces readability. How about this?
Looking at the git history, CreateWorkExprContext was introduced in
50a38f651, and at that time it did some nontrivial calculations
to adjust that initial value of maxBlockSize. Later, cc721c459
simplified matters but forgot to remove the now-useless
initialization. So +1, unless Jeff has some reason to keep it
like this?
regards, tom lane
view thread (2+ messages)
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected], [email protected]
Subject: Re: Remove redundant assignment in CreateWorkExprContext
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox