Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jJJlb-0004GK-HY for pgsql-hackers@arkaria.postgresql.org; Tue, 31 Mar 2020 16:29:31 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1jJJla-00087h-E3 for pgsql-hackers@arkaria.postgresql.org; Tue, 31 Mar 2020 16:29:30 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jJJla-00085u-2l for pgsql-hackers@lists.postgresql.org; Tue, 31 Mar 2020 16:29:30 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jJJlY-0002eQ-01 for pgsql-hackers@lists.postgresql.org; Tue, 31 Mar 2020 16:29:29 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id 02VGTP8S009663; Tue, 31 Mar 2020 12:29:25 -0400 From: Tom Lane To: Alexey Bashtanov cc: pgsql-hackers@lists.postgresql.org Subject: Re: Less-silly selectivity for JSONB matching operators In-reply-to: <7e87d82d-326a-a8df-ee4f-ec708c701dce@imap.cc> References: <12237.1582833074@sss.pgh.pa.us> <14469.1582927774@sss.pgh.pa.us> <8fcbdcc5-cbed-f96f-7ed4-f34d1bd1a205@imap.cc> <9233.1585671632@sss.pgh.pa.us> <7e87d82d-326a-a8df-ee4f-ec708c701dce@imap.cc> Comments: In-reply-to Alexey Bashtanov message dated "Tue, 31 Mar 2020 17:26:14 +0100" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <9661.1585672165.1@sss.pgh.pa.us> Date: Tue, 31 Mar 2020 12:29:25 -0400 Message-ID: <9662.1585672165@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Alexey Bashtanov writes: >> So that leaves us with needing >> to find a better name for this new one. Any ideas? > I'm thinking of something wide like > opersel, operjoinsel, DEFAULT_OPER_SEL > or maybe even > genericsel, genericjoinsel, DEFAULT_GENERIC_SEL Seems a little *too* generic :-( I was wondering about DEFAULT_MATCHING_SEL. The difference in purpose from DEFAULT_MATCH_SEL wouldn't be too obvious, but then it probably wouldn't be anyway. regards, tom lane