Subject: Wrong comment for ReplicationSlotCreate

From: Daniil Davydov <[email-masked]>
Date: Mon, 29 Dec 2025 20:39:36 +0700

Hi,

I noticed that the comment for ReplicationSlotCreate function contains this
description for the "two_phase" option :

 * two_phase: Allows decoding of prepared transactions. We allow this option
 *     to be enabled only at the slot creation time. If we allow this option
 *     to be changed during decoding then it is quite possible that we skip
 *     prepare first time because this option was not enabled. Now next time
 *     during getting changes, if the two_phase option is enabled it can skip
 *     prepare because by that time start decoding point has been moved. So the
 *     user will only get commit prepared.

But commit [1] introduced the ability to alter the "two_phase" option for the
replication slot. Thus, I guess that the comment mentioned above is
outdated and we should change it.

[1] 1462aad2e4474ab61174f8ab00992cd3d6d57c7b

--
Best regards,
Daniil Davydov
From 9545671c48ee75ee7f9eed26af0902fcd3114573 Mon Sep 17 00:00:00 2001
From: Daniil Davidov <[email-masked]>
Date: Mon, 29 Dec 2025 20:27:11 +0700
Subject: [PATCH] Fix comment for ReplicationSlotCreate

---
 src/backend/replication/slot.c | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)

diff --git a/src/backend/replication/slot.c b/src/backend/replication/slot.c
index 58c41d45516..310dcfcbd5f 100644
--- a/src/backend/replication/slot.c
+++ b/src/backend/replication/slot.c
@@ -369,13 +369,7 @@ IsSlotForConflictCheck(const char *name)
  * name: Name of the slot
  * db_specific: logical decoding is db specific; if the slot is going to
  *	   be used for that pass true, otherwise false.
- * two_phase: Allows decoding of prepared transactions. We allow this option
- *     to be enabled only at the slot creation time. If we allow this option
- *     to be changed during decoding then it is quite possible that we skip
- *     prepare first time because this option was not enabled. Now next time
- *     during getting changes, if the two_phase option is enabled it can skip
- *     prepare because by that time start decoding point has been moved. So the
- *     user will only get commit prepared.
+ * two_phase: If enabled, allows decoding of prepared transactions.
  * failover: If enabled, allows the slot to be synced to standbys so
  *     that logical replication can be resumed after failover.
  * synced: True if the slot is synchronized from the primary server.
-- 
2.43.0

---

From: Chao Li <[email-masked]>
Date: Tue, 30 Dec 2025 17:18:10 +0800

> On Dec 29, 2025, at 21:39, Daniil Davydov <[email-masked]> wrote:
> 
> Hi,
> 
> <0001-Fix-comment-for-ReplicationSlotCreate.patch>

The old comment claimed “We allow this option to be enabled only at the slot creation time” that is no longer true after commit 1462aad2e4474ab61174f8ab00992cd3d6d57c7b, so yes, the old comment need updating.

But I think the updated version is too simple. It loses the information that enabling two_phase later can result in missing PREPARE.

So, I would suggest something like:
```
* two_phase: If enabled, allows decoding of prepared transactions.
*     Note that enabling this option after decoding has already advanced
*     may result in missing PREPARE records for transactions that were
*     prepared before the option was enabled.

```

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: Daniil Davydov <[email-masked]>
Date: Tue, 30 Dec 2025 17:07:22 +0700

Hi,

> *     prepared before the option was enabled.

Thanks for the review!

As far as I understand, if the publisher prepares a transaction and
then subscriber
tries to create a subscription, walsender will wait until the prepared
transaction is
finished (during execution of  CREATE_REPLICATION_SLOT command).
We can find this logic inside the SnapBuildFindSnapshot function. Thus, we
cannot miss any PREPARE record for the created slot.

Am I missing something?

--
Best regards,
Daniil Davydov

---

From: Chao Li <[email-masked]>
Date: Wed, 31 Dec 2025 10:32:17 +0800

> On Dec 30, 2025, at 18:07, Daniil Davydov <[email-masked]> wrote:
> 
> Hi,
> 

You’re right that during CREATE_REPLICATION_SLOT, SnapBuildFindSnapshot() ensures we don’t miss PREPARE records for prepared transactions that exist at creation time.

1462aad2e introduced support for altering logical replication slot options, including two_phase, after the slot has been created. The commit comment says:
```
    Changing the 'two_phase' option for a subscription from 'true' to 'false'
    is permitted only when there are no pending prepared transactions
    corresponding to that subscription. Otherwise, the changes of already
    prepared transactions can be replicated again along with their corresponding
    commit leading to duplicate data or errors.
```

true->false is not allowed, however false->true is permitted. So, I think the old comment is still possible today:
```
*     Note that enabling this option after decoding has already advanced
*     may result in missing PREPARE records for transactions that were
*     prepared before the option was enabled.
```

Best regards,