Subject: Cleanup explain_memoize function after test

From: Kirill Reshke <[email-masked]>
Date: Wed, 22 Apr 2026 11:49:32 +0500

Hi!

I was doing some hacking today, when I noticed that the memoize
regression test does not clean up the explain_memoize function after
its end. I checked other regression tests and they tend to do it. So,
I am not sure if there is a rule about `you should drop all objects
that you create in regression test`, but if there is such a rule, PFA.

-- 
Best regards,
Kirill Reshke

---

From: Chao Li <[email-masked]>
Date: Wed, 22 Apr 2026 17:24:33 +0800

> On Apr 22, 2026, at 14:49, Kirill Reshke <[email-masked]> wrote:
> 
> Hi!
> 
> <v1-0001-Cleanup-explain_memoize-after-resgression-test.patch>

Good catch.

You also need to update the corresponding out file, otherwise the test will fail. I have helped update the out file in v2, now “make check” passes with v2 applied.

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: Bertrand Drouvot <[email-masked]>
Date: Wed, 22 Apr 2026 17:32:27 +0000

Hi,

> You also need to update the corresponding out file, otherwise the test will fail. I have helped update the out file in v2, now “make check” passes with v2 applied.

I'm not sure fixing "only" this single missing clean up makes sense. I think,
that the main purpose of those would be to be able to run "make installcheck EXTRA_REGRESS_OPTS="--use-existing""
multiple times on the same running instance without any errors. If that's the
case, then from what I can see after a quick test, the task would be way larger
that this patch.

Regards,

-- 
Bertrand Drouvot
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com