public inbox for [email protected]  
help / color / mirror / Atom feed
From: Robert Haas <[email protected]>
To: Guillaume Lelarge <[email protected]>
Cc: Michael Christofides <[email protected]>
Cc: David Rowley <[email protected]>
Cc: David G. Johnston <[email protected]>
Cc: Nikolay Samokhvalov <[email protected]>
Cc: Tom Lane <[email protected]>
Cc: [email protected]
Subject: Re: Proposals for EXPLAIN: rename ANALYZE to EXECUTE and extend VERBOSE
Date: Tue, 12 Nov 2024 16:21:35 -0500
Message-ID: <CA+TgmoZO2HtDGHf7K4rmNdfUGuS=ngsPgwrH=JdyF6Okcnzfkw@mail.gmail.com> (raw)
In-Reply-To: <CAECtzeWpusNrZADkQ01ZZL_fFtOWtwtnw_uixqy9hgK0qUCScQ@mail.gmail.com>
References: <CANNMO++9W_UA8PB9AkDRF3JBv4K7K1FnisrXTjicL+WZhwUJzw@mail.gmail.com>
	<CA+TgmoZF7PbO7DB_VMQS4664EgOdObhFtAoLUb83bp3i-623UQ@mail.gmail.com>
	<CANNMO++d9CKuJEzSnRWFCHcmKr2DGASTtEMZ9bpEYHSa4QFQvA@mail.gmail.com>
	<[email protected]>
	<CANNMO++W7MM8T0KyXN3ZheXXt-uLVM3aEtZd+WNfZ=obxffUiA@mail.gmail.com>
	<CAKFQuwbLq3GWoJw-zNa43pkcfg5gh4gGQKMptQtp4qX_nQL9AQ@mail.gmail.com>
	<CAApHDvrYwEt=ueMTn39okNihZffhKgqvxedLqDJu=hmSsZ=g9Q@mail.gmail.com>
	<CAFwT4nC5255GkSt1WEfTHi6cwUuY4fjUmH15nD91c1JvNoOxNA@mail.gmail.com>
	<CAECtzeUKbyZNuFRu4DTr_3p44egDXGbPpGonixqJninWXyBvnQ@mail.gmail.com>
	<CA+TgmobY4N3QYWTW4bj9K=gG3Q4rTAsZLvi_=ODZYRBpk=ZVNA@mail.gmail.com>
	<CAECtzeVvrjxXmE3TB9zz3MD_RwiE=MCg2Xjx0HXoSn4e-VRSOg@mail.gmail.com>
	<CAECtzeWpusNrZADkQ01ZZL_fFtOWtwtnw_uixqy9hgK0qUCScQ@mail.gmail.com>

On Tue, Nov 12, 2024 at 4:02 PM Guillaume Lelarge
<[email protected]> wrote:
> Sure looks easy enough to do (though it still lacks doc and tests changes). See patch attached.

Yep, that's very small. I'm a bit wondering if it's too small, though.
standard_ExplainOneQuery() seems to do some stuff with es->buffers
even before it does planning, so if the idea is that this will be a
noop without ANALYZE, maybe this doesn't implement that. Also, you
should probably update the default value for auto_explain.log_buffers.
In general, I would recommend "git grep 'es->buffers'" and look
carefully at each place where it's mentioned and decide if anything
needs to be changed. And then change the stuff that needs it, and
include in your email an explanation of why the other things don't
need to be changed, unless it's obvious.

-- 
Robert Haas
EDB: http://www.enterprisedb.com






view thread (20+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected]
  Subject: Re: Proposals for EXPLAIN: rename ANALYZE to EXECUTE and extend VERBOSE
  In-Reply-To: <CA+TgmoZO2HtDGHf7K4rmNdfUGuS=ngsPgwrH=JdyF6Okcnzfkw@mail.gmail.com>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox