Subject: Re: Proposal: new file format for hba/ident/hosts configuration?

From: Andrew Dunstan <[email-masked]>
Date: Thu, 9 Jul 2026 17:19:30 -0400

>
> Freeze the parsing of old-style files; new features and changes go only in
> the new format. This should eliminate (well, almost eliminate) the
> maintenance burden associated with having two file formats.
>

That's the scenario Tom warned against upthread.

cheers

andrew

---

From: Jacob Champion <[email-masked]>
Date: Thu, 9 Jul 2026 14:43:17 -0700

On Thu, Jul 9, 2026 at 2:19 PM Andrew Dunstan <[email-masked]> wrote:
>> Freeze the parsing of old-style files; new features and changes go only in the new format. This should eliminate (well, almost eliminate) the maintenance burden associated with having two file formats.
>

But if, hypothetically, a new format were indeed a big improvement for
people, it's probably what we should do.

--Jacob