Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1nMM0L-0000SO-C1 for pgsql-hackers@arkaria.postgresql.org; Tue, 22 Feb 2022 03:38:21 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1nMLzn-0006Ff-8Y for pgsql-hackers@arkaria.postgresql.org; Tue, 22 Feb 2022 03:37:47 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1nMLzm-0006FW-Tc for pgsql-hackers@lists.postgresql.org; Tue, 22 Feb 2022 03:37:46 +0000 Received: from mail-yb1-xb2d.google.com ([2607:f8b0:4864:20::b2d]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.92) (envelope-from ) id 1nMLzj-000655-2U for pgsql-hackers@postgresql.org; Tue, 22 Feb 2022 03:37:45 +0000 Received: by mail-yb1-xb2d.google.com with SMTP id b35so10564108ybi.13 for ; Mon, 21 Feb 2022 19:37:42 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20210112; h=mime-version:references:in-reply-to:from:date:message-id:subject:to :cc; bh=vm0ULzedUXEUzAUn6S+PaMz/e24vaiDyFyk+VQX3tdc=; b=kPy+2j0pEe7Umo+ZjIw33nROi4mnXdy4sHNY7WfNNYozN5MYkrTRlELqdtE4l598a8 QIsiU6atbp71zHjllW40RC/TDwNCtWOXg+9sT/e+v2cFJ7WKixuJUK7kYan2ttpEnJmx +gRhq6PpHsF3aqoHgXo5oZigfuR9/JKTncmz7C5ftEcqF+L7Ivevhy+xSUytEEmdcar0 PJynfS4rKlQW9qzbUr1CdVHJDqp5tClWQzsH9AooUGRku4XgY/a0YJtV0k9rC/8jlJCB mIR1OpQoABbDDc7S9Uv9E6gDQzh/9IMap731jMU/vSM1ZLwm/qr3GuYOpTbVvFjfRPyP fkzg== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20210112; h=x-gm-message-state:mime-version:references:in-reply-to:from:date :message-id:subject:to:cc; bh=vm0ULzedUXEUzAUn6S+PaMz/e24vaiDyFyk+VQX3tdc=; b=H2tQC3nFSlqK70d1VAV5FTWtORYxMDah2EzI78gDXKF1S8D0oyknbdH5gOdcsx/WTG rTYAJpNbHt+FoyIo7Qo+xy9/SCLdgSMVYFMuIgBSSVoixiiodKiKI7UB563J6WifRJri ezH2jEZvKKI2oImdaP7ADPBxec4ps0G9k2DswqIPKC2OMhx9E9kykcFHUmvTHAc1O96m 1UPjsTe4LlgjvIXz5u1sOKZxhAVZRfoqO++FZZ46mGZf/NT44vfIkB33zw7YYT466lag kYwEwDuRs/HlpoKH9QNgLAwK2BnoTMsBG4Ip6n38/cwAI34XevfCG6wXxkeFoEI+pWkf cwXg== X-Gm-Message-State: AOAM532ovpEY/TdaAbMMM1l3OCSBtAGSurqU835J7UtiJ7kMDraQnzC8 q3XZ60Wdzpo4lEyDg9U0fVe3He7DlO3kl7qNXYU= X-Google-Smtp-Source: ABdhPJz8KLo+CXdf45eRJ2oFFTTh0QccQNM39TbleBxfszbhbrvGsqY/pHAJMl5JQZqDJmOTM1buYJHuexocdt8fvsw= X-Received: by 2002:a25:d2c3:0:b0:623:f9ef:62c3 with SMTP id j186-20020a25d2c3000000b00623f9ef62c3mr21348457ybg.495.1645501061263; Mon, 21 Feb 2022 19:37:41 -0800 (PST) MIME-Version: 1.0 References: <20220215182641.2cejma6tcgeoqyw2@alap3.anarazel.de> <20220218203255.d3evl6qi2n6gxy6b@alap3.anarazel.de> <20220219160203.y5w2ktc2utthn7pe@alap3.anarazel.de> <20220221053453.lo6fzmji23ennvgj@alap3.anarazel.de> <20220221074806.nyhdberpuwbcbudp@alap3.anarazel.de> In-Reply-To: From: Amit Kapila Date: Tue, 22 Feb 2022 09:07:30 +0530 Message-ID: Subject: Re: Design of pg_stat_subscription_workers vs pgstats To: "David G. Johnston" Cc: Andres Freund , Masahiko Sawada , pgsql-hackers Content-Type: text/plain; charset="UTF-8" List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk On Mon, Feb 21, 2022 at 9:37 PM David G. Johnston wrote: > > On Mon, Feb 21, 2022 at 2:19 AM Amit Kapila wrote: >> >> On Mon, Feb 21, 2022 at 1:18 PM Andres Freund wrote: >> >> > > The view name could be pg_stat_subscription_lrep, >> > > pg_stat_logical_replication, or something on those lines. >> > >> > pg_stat_subscription_stats :) >> > >> >> Having *stat* two times in the name sounds slightly odd to me but let >> us see what others think. One more option could be >> pg_stat_subscription_replication. >> > > Agreed. > > pg_stat_subscription_activity > > We already have pg_stat_activity (which may be an argument against the suggestion...) > I don't know if that can be an argument against it but one can imagine that we record other subscription changes like (change of publications, etc.). I personally feel it may be better to add '_replication' in some way like pg_stat_sub_replication_activity but I am fine either way. -- With Regards, Amit Kapila.