Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1rSUZm-00E5uK-KW for pgsql-hackers@arkaria.postgresql.org; Wed, 24 Jan 2024 04:09:23 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1rSUZk-001a1q-SM for pgsql-hackers@arkaria.postgresql.org; Wed, 24 Jan 2024 04:09:20 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1rSUZk-001a1i-Ib for pgsql-hackers@lists.postgresql.org; Wed, 24 Jan 2024 04:09:20 +0000 Received: from mail-oa1-x36.google.com ([2001:4860:4864:20::36]) by magus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (Exim 4.94.2) (envelope-from ) id 1rSUZf-003PJc-2L for pgsql-hackers@postgresql.org; Wed, 24 Jan 2024 04:09:19 +0000 Received: by mail-oa1-x36.google.com with SMTP id 586e51a60fabf-21432e87455so1807570fac.1 for ; Tue, 23 Jan 2024 20:09:14 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1706069353; x=1706674153; darn=postgresql.org; h=content-transfer-encoding:cc:to:subject:message-id:date:from :in-reply-to:references:mime-version:from:to:cc:subject:date :message-id:reply-to; bh=vyNp+53mbcdIUwCjGUrwNxUqRy0C9woVFXI+rRNQN1o=; b=gDnfLyBSjrbfPVA1cv2Re9UPUAdOYjuruZYggs+BbWwnpG6z3qoWhYh+abN3yVUqPo mgn7SSCkrlgKZyxfVKbxZXIyGTte/TgApSIrFd88kc/Lf2IHm6Chr6J49EqUD8E3dsCE kuUnRi70KIuIbyqyn8tDZmVJ/TGQCZhmc9jtaTE6uYAbeyAXLqG4UnYPnNWhgOqkf1WS SHv1z+sfo48DF6nWQ7B36o+cq654c06b2JrAU96F5ePxfwaXUCIsouOemz5TqF/LFqL+ bROyklL1fT9uOk4/wQbBrTfI23oVL1PSoktB4/l7Jg/wavnMJy4KkTYfFefVWw7VCna5 2EmA== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1706069353; x=1706674153; h=content-transfer-encoding:cc:to:subject:message-id:date:from :in-reply-to:references:mime-version:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=vyNp+53mbcdIUwCjGUrwNxUqRy0C9woVFXI+rRNQN1o=; b=WeopX8W/EGIGlECdjld4vKWWH58TNvrsKm/2SS5Ncq2O+vdXBnudiCO6yurXFn2CDi /19ZZNDbdSHCNdP9kmxr1dhJgtVjfOPph+KcKqINOvof6O1YkH6+O8ODPsc9ZP4WtUBv fhXqIkqzqdqIuLdZRZ2pEnwR1pYtJ9mwwncJw3f1rthFSO2qQNjbxNjrlpEClowcGjfz JI0S9GgfgJYBppD8ST5Wkhtxkv8+jZOli1lPOZlb24UcTCQNPL3ivuxxmfOTAfe/nIpa cxW3eM7AP256VtVvxExbNwepnzc7OoFLRy2nY2fGNkTTmKXaYkQnjJSwQqxSTv1Cecjb IsNg== X-Gm-Message-State: AOJu0Yz56BXldawTAHHuKPWMv5aYQ7SaBPulB7eqAlSFWCN2nAKy+tf6 OMLyzvs4wT9rVhoFhNPDK6mZ4JQGTs//0SWDjCvtu6BT3+5Vmzzcb+LYLHHV8peAO2e4Wf999uf HtkBH6//ygDJPXANvWDzWi9Bux2s= X-Google-Smtp-Source: AGHT+IGr7Kp3Gj/h/pSZgolN9sXB0nVVSs3MPJ8t4uFHbgtN2UMrllNncsTRBFSb9r8M9nugcaSdLP11n5PLtF6jV7s= X-Received: by 2002:a05:6871:3b33:b0:214:3b22:857e with SMTP id pw51-20020a0568713b3300b002143b22857emr1607073oac.42.1706069352610; Tue, 23 Jan 2024 20:09:12 -0800 (PST) MIME-Version: 1.0 References: In-Reply-To: From: Amit Kapila Date: Wed, 24 Jan 2024 09:39:01 +0530 Message-ID: Subject: Re: Synchronizing slots from primary to standby To: Peter Smith Cc: shveta malik , Ajin Cherian , Bertrand Drouvot , Masahiko Sawada , "Zhijie Hou (Fujitsu)" , Dilip Kumar , Nisha Moond , "Hayato Kuroda (Fujitsu)" , Bharath Rupireddy , Peter Eisentraut , Bruce Momjian , Ashutosh Sharma , Andres Freund , pgsql-hackers , Alvaro Herrera Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: quoted-printable List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk On Wed, Jan 24, 2024 at 8:52=E2=80=AFAM Peter Smith = wrote: > > Here are some comments for patch v66-0001. > > =3D=3D=3D=3D=3D=3D > doc/src/sgml/catalogs.sgml > > 1. > + > + If true, the associated replication slots (i.e. the main slot and= the > + table sync slots) in the upstream database are enabled to be > + synchronized to the physical standbys > + > > /physical standbys/physical standby/ > > I wondered if it is better just to say singular "standby" instead of > "standbys" in places like this; e.g. plural might imply cascading for > some readers. > I don't think it is confusing as we used in a similar way in docs. We can probably avoid using physical in places similar to above as that is implied > > > =3D=3D=3D=3D=3D=3D > src/backend/replication/slotfuncs.c > > 11. create_physical_replication_slot > > /* acquire replication slot, this will check for conflicting names */ > ReplicationSlotCreate(name, false, > - temporary ? RS_TEMPORARY : RS_PERSISTENT, false); > + temporary ? RS_TEMPORARY : RS_PERSISTENT, false, > + false); > > Having an inline comment might be helpful here instead of passing "false,= false" > > SUGGESTION > ReplicationSlotCreate(name, false, > temporary ? RS_TEMPORARY : RS_PERSISTENT, false, > false /* failover */); > I don't think we follow to use of inline comments. I feel that sometimes makes code difficult to read considering when we have multiple such parameters. --=20 With Regards, Amit Kapila.