Subject: Re: Hashed IN only applied to first encountered IN

From: David Rowley <[email-masked]>
Date: Wed, 2 Apr 2025 12:00:01 +1300

On Wed, 2 Apr 2025 at 01:31, David Rowley <[email-masked]> wrote:
>
> On Wed, 2 Apr 2025 at 00:51, David Geier <[email-masked]> wrote:
> > The hashed IN optimization is only applied to the first encountered
> > ScalarArrayOpExpr during the expression tree traversal in
> > convert_saop_to_hashed_saop_walker(). Reason being that the walker
> > returns true which aborts the traversal.
>
> > I've also attached a patch with a fix.
>
> Thanks for the report and fix.  On first inspection your patch looks
> fine.  I'll have a closer look tomorrow.

I've now pushed and backpatched the relevant portion of this back to v14.

Thanks again.

David

---

From: David Geier <[email-masked]>
Date: Wed, 2 Apr 2025 11:44:28 +0200

Great!

Thank you!