Subject: [PATCH] Fix Int32GetDatum used for bool column in CREATE SUBSCRIPTION

From: Lakshmi N <[email-masked]>
Date: Sun, 26 Apr 2026 22:33:00 -0700

Hi hackers,

In CreateSubscription(), the subretentionactive catalog column (declared as
bool in pg_subscription.h) is populated using Int32GetDatum() instead of
BoolGetDatum():

This writes 4 bytes into a 1-byte bool Datum. It is inconsistent with the
ALTER SUBSCRIPTION path which correctly uses BoolGetDatum().

The attached patch fixes this to use BoolGetDatum(), matching both the
catalog definition and the ALTER path.

Regards,
Lakshmi

---

From: Nisha Moond <[email-masked]>
Date: Mon, 27 Apr 2026 13:58:58 +0530

> catalog definition and the ALTER path.

+1
This looks like an oversight in commit a850be2.

--
Thanks,
Nisha

---

From: Amit Kapila <[email-masked]>
Date: Tue, 28 Apr 2026 16:27:45 +0530

> This looks like an oversight in commit a850be2.

Pushed.

-- 
With Regards,
Amit Kapila.