Subject: Re: Minor refactor of the code in ExecScanExtended()

From: Aditya Gollamudi <[email-masked]>
Date: Sun, 18 Jan 2026 20:50:41 -0800

On Sun, Jan 18, 2026 at 7:31 PM cca5507 <[email-masked]> wrote:

> Hi,
>
> The current code:
>
> if (!qual && !projInfo)
> {
> ResetExprContext(econtext);
> return ExecScanFetch(node, epqstate, accessMtd, recheckMtd);
> }
>
> ResetExprContext(econtext);
>
> The following format might be simpler:
>
> ResetExprContext(econtext);
>
> if (!qual && !projInfo)
> return ExecScanFetch(node, epqstate, accessMtd, recheckMtd);
>
> Attach a patch to do this.
>
> --
> Regards,
> ChangAo Chen
>
> Hi,

+1, seems like a simple refactor.
Tests are passing locally for me!

- Adi Gollamudi

---

From: Henson Choi <[email-masked]>
Date: Wed, 25 Mar 2026 10:53:55 +0900

Hi hackers,

> Tests are passing locally for me!

+1, agreed.

The refactored version is cleaner and easier to read by moving
ResetExprContext() before the early return,
eliminating the duplicated logic.

Best regards,
Henson