Subject: Add tab completion for SERVER and CONNECTION keywords in psql

From: Yamaguchi Atsuo <[email-masked]>
Date: Sun, 22 Mar 2026 13:30:30 -0700

Hi,

This patch adds missing tab completion support in psql for:

- SERVER keyword after ALTER/CREATE SUBSCRIPTION <name>
- CONNECTION keyword after ALTER/CREATE FOREIGN DATA WRAPPER <name>

Currently, typing "ALTER SUBSCRIPTION sub1 SERVER" and pressing Tab
does not complete server names, even though the SERVER keyword itself
is already suggested. Similarly, CONNECTION is not suggested as a
completion candidate for FOREIGN DATA WRAPPER commands, despite being
a valid option.

The patch is generated against the current master branch.

Regards,
Atsuo Yamaguchi

---

From: Masahiko Sawada <[email-masked]>
Date: Mon, 23 Mar 2026 13:14:04 -0700

Hi,

> The patch is generated against the current master branch.

It's a fix for an oversight of commit 8185bb5347 rather than proposing
a new tab-completion. Good catch. Regarding the patch, I have one
comment:

    /* ALTER FOREIGN DATA WRAPPER <name> */
    else if (Matches("ALTER", "FOREIGN", "DATA", "WRAPPER", MatchAny))
        COMPLETE_WITH("HANDLER", "VALIDATOR", "NO",
-                     "OPTIONS", "OWNER TO", "RENAME TO");
+                     "OPTIONS", "OWNER TO", "RENAME TO", "CONNECTION");

I think it's better to maintain the keywords in the list in alphabetical order.

Regards,

-- 
Masahiko Sawada
Amazon Web Services: https://aws.amazon.com

---

From: Yamaguchi Atsuo <[email-masked]>
Date: Wed, 25 Mar 2026 08:43:58 -0700

Hi,

> I think it's better to maintain the keywords in the list in alphabetical

 Thank you for the review. I have updated the code to maintain the keywords
in alphabetical order.

Regards,
Atsuo Yamaguchi

---

From: Masahiko Sawada <[email-masked]>
Date: Wed, 25 Mar 2026 09:33:03 -0700

On Wed, Mar 25, 2026 at 8:44 AM Yamaguchi Atsuo <[email-masked]> wrote:
>
> Hi,
>
> On Mon, Mar 23, 2026 at 1:14 PM Masahiko Sawada <[email-masked]> wrote:
>>
>> Hi,
>>
>  Thank you for the review. I have updated the code to maintain the keywords in alphabetical order.

Thank you for updating the patch! Pushed.

Regards,