Subject: Property graph: fix error handling when dropping non-existent label property

From: Chao Li <[email-masked]>
Date: Fri, 24 Apr 2026 15:32:38 +0800

Hi,

I am testing graph tables today and noticed an improper error message when dropping a property.

Here is a simple repro:
```
evantest=# CREATE TABLE t1 (a int PRIMARY KEY, b int);
CREATE TABLE
evantest=#
evantest=# CREATE PROPERTY GRAPH g
evantest-#     VERTEX TABLES (
evantest(#         t1
evantest(#             LABEL l1 PROPERTIES (a AS p1)
evantest(#             LABEL l2 PROPERTIES (b AS p2)
evantest(#     );
CREATE PROPERTY GRAPH
evantest=#
evantest=# ALTER PROPERTY GRAPH g
evantest-#     ALTER VERTEX TABLE t1
evantest-#     ALTER LABEL l1 DROP PROPERTIES (p2);
ERROR:  could not find tuple for label property 0
```

This does not look like a normal user-facing SQL error message.

Looking into the code, AlterPropGraph() checks whether the property exists in the graph, but does not check if label property exists. As a result, InvalidOid can be passed to ObjectAddressSet() and then to performDeletion().

The fix is simple, just check the label-property OID before trying to delete it. I also added a regress test.

With the patch, the error becomes:
```
evantest=# ALTER PROPERTY GRAPH g
evantest-#     ALTER VERTEX TABLE t1
evantest-#     ALTER LABEL l1 DROP PROPERTIES (p2);
ERROR:  property graph "g" element "t1" label "l1" has no property "p2"
```

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: Ashutosh Bapat <[email-masked]>
Date: Fri, 24 Apr 2026 18:08:07 +0530

> ERROR:  property graph "g" element "t1" label "l1" has no property "p2"

Thanks for the report. Agree that we need to provide a correct error
message. The code changes look good to me. However, the way you have
written this code is different from similar code earlier in the
function. Either your code should match that style or that code should
be changed to your style. I like your way - reduces code a bit and
does not repeat ereport. I also noticed that the code to fetch the
element label oid from element_alias and label name is repeated along
with the ereport in a few places. I think we could instead write a
function to do that and call that function in those places. When
writing the function, we could change that code to use your style.

-- 
Best Wishes,
Ashutosh Bapat

---

From: Chao Li <[email-masked]>
Date: Sun, 26 Apr 2026 15:21:14 +0800

> On Apr 24, 2026, at 20:38, Ashutosh Bapat <[email-masked]> wrote:
> 
> message. The code changes look good to me.

Cool! Thanks for reviewing and confirming.

> However, the way you have

I updated the nearby code to align with my style. PFA v2.

Best regards,

---

From: Ashutosh Bapat <[email-masked]>
Date: Tue, 28 Apr 2026 20:31:56 +0530

> I updated the nearby code to align with my style. PFA v2.

Looks good to me. However, I did change OidIsValid() and !OidIsValid()
back to (oid) and (!oid) conditions to be consistent with the rest of
the code.

I tried to deduplicate the code which finds element labelid from given
element alias and label name. But there is one place where we also use
the label oid and or the element oid that the code extracts. So it
didn't end up being a lot of improvement.

Since this patch conflicts with the patch at [1], I am posting this
patch along with the patch there on that thread so that both can be
committed without causing a merge conflict. If necessary we can
continue discussion here.

[1] https://www.postgresql.org/message-id/[email-masked]

-- 
Best Wishes,
Ashutosh Bapat

---

From: Chao Li <[email-masked]>
Date: Wed, 29 Apr 2026 14:01:19 +0800

> On Apr 28, 2026, at 23:01, Ashutosh Bapat <[email-masked]> wrote:
> 

In the file, I also see:
```
    if (pgrelid == InvalidOid)
```

Should we take this opportunity to change to use OidIsValid() everywhere in the file? As this feature is new to PG19, we can cleanup the inconsistency before releasing v19. Otherwise some people might also file a cleanup patch for this in the future.

> continue discussion here.

Reasonable.

Best regards,

---

From: Álvaro Herrera <[email-masked]>
Date: Wed, 29 Apr 2026 11:51:55 +0200

On 2026-04-29, Chao Li wrote:

> Should we take this opportunity to change to use OidIsValid() 
> everywhere in the file? As this feature is new to PG19, we can cleanup 
> the inconsistency before releasing v19. Otherwise some people might 
> also file a cleanup patch for this in the future.

Yeah, I find "if (oid)" a rather terrible coding pattern. The negative one is perhaps not so bad, but I'd keep both cases similar by using the macro in both, for consistency.

-- 
Álvaro Herrera

---

From: Ashutosh Bapat <[email-masked]>
Date: Wed, 29 Apr 2026 17:40:32 +0530

> Yeah, I find "if (oid)" a rather terrible coding pattern. The negative one is perhaps not so bad, but I'd keep both cases similar by using the macro in both, for consistency.

I am in favour of doing this change, but let's do it in a separate patch.

-- 
Best Wishes,
Ashutosh Bapat