Subject: Typo fixes in Graph table files

From: Lakshmi N <[email-masked]>
Date: Tue, 14 Apr 2026 23:58:01 -0700

Hi Hackers,

Fixed a few typos in the graph table files and attached a patch.
Please review.

Regards,
Lakshmi

---

From: Ashutosh Bapat <[email-masked]>
Date: Wed, 15 Apr 2026 20:38:07 +0530

Hi Lakshmi,

> Fixed a few typos in the graph table files and attached a patch.

Thanks for the report and patch.

I fixed some more typos and grammar in the attached patch. Also
simplified a comment.

--
Best Wishes,
Ashutosh Bapat
From 9df7b778d7ec6ad1a11d07061d501c15fd98c614 Mon Sep 17 00:00:00 2001
From: Ashutosh Bapat <[email-masked]>
Date: Wed, 15 Apr 2026 17:52:19 +0530
Subject: [PATCH v20260415 3/3] Fix typos and grammar in graph table rewrite
 code

Reported-by: Lakshmi N <[email-masked]>
Author: Lakshmi N <[email-masked]>
Author: Ashutosh Bapat <[email-masked]>
Discussion: https://www.postgresql.org/message-id/CA+3i_M9gpUGjH-BkJk=[email-masked]
---
 src/backend/commands/propgraphcmds.c    | 12 ++++++------
 src/backend/rewrite/rewriteGraphTable.c | 14 +++++++-------
 2 files changed, 13 insertions(+), 13 deletions(-)

diff --git a/src/backend/commands/propgraphcmds.c b/src/backend/commands/propgraphcmds.c
index 45d2ff1bbba..3842f4a711b 100644
--- a/src/backend/commands/propgraphcmds.c
+++ b/src/backend/commands/propgraphcmds.c
@@ -414,7 +414,7 @@ propgraph_edge_get_ref_keys(ParseState *pstate, const List *keycols, const List
 			 * right operand. The method used to find the equality operators
 			 * is similar to the method used to find equality operators for
 			 * FK/PK comparison in ATAddForeignKeyConstraint() except that
-			 * opclass of the the vertex key type is used as a starting point.
+			 * opclass of the vertex key type is used as a starting point.
 			 * Since we need only equality operators we use both BT and HASH
 			 * strategies.
 			 *
@@ -1045,7 +1045,7 @@ insert_property_record(Oid graphid, Oid ellabeloid, Oid pgerelid, const char *pr
  * makes it easier to share this code between CREATE PROPERTY GRAPH and ALTER
  * PROPERTY GRAPH.  We pass in the element OID so that ALTER PROPERTY GRAPH
  * only has to check the element it has just operated on.  CREATE PROPERTY
- * GROUP checks all elements it has created.
+ * GRAPH checks all elements it has created.
  */
 static void
 check_element_properties(Oid peoid)
@@ -1214,8 +1214,8 @@ check_element_label_properties(Oid ellabeloid)
 
 	/*
 	 * Find a reference element label to fetch label properties.  The
-	 * reference element label has to have the label OID as the one being
-	 * checked but be distinct from the one being checked.
+	 * reference element label has to have the same label OID as the one being
+	 * checked but a different element OID.
 	 */
 	ScanKeyInit(&key[0],
 				Anum_pg_propgraph_element_label_pgellabelid,
@@ -1237,7 +1237,7 @@ check_element_label_properties(Oid ellabeloid)
 	table_close(rel, AccessShareLock);
 
 	/*
-	 * If there is not previous definition of this label, then we are done.
+	 * If there is no previous definition of this label, then we are done.
 	 */
 	if (!ref_ellabeloid)
 		return;
@@ -1669,7 +1669,7 @@ AlterPropGraph(ParseState *pstate, const AlterPropGraphStmt *stmt)
 	/*
 	 * Invalidate relcache entry of the property graph so that the queries in
 	 * the cached plans referencing the property graph will be rewritten
-	 * considering changes to the propert graph.
+	 * considering changes to the property graph.
 	 */
 	CacheInvalidateRelcacheByRelid(pgrelid);
 
diff --git a/src/backend/rewrite/rewriteGraphTable.c b/src/backend/rewrite/rewriteGraphTable.c
index 429ef1cf1f4..918c6c7b56c 100644
--- a/src/backend/rewrite/rewriteGraphTable.c
+++ b/src/backend/rewrite/rewriteGraphTable.c
@@ -163,10 +163,10 @@ rewriteGraphTable(Query *parsetree, int rt_index)
  * done by generate_queries_for_path_pattern_recurse().
  * generate_query_for_graph_path() constructs a query for a given path.
  *
- * A path pattern may result into no path if any of the element pattern yields no
- * elements or edge patterns yield no edges connecting adjacent vertex patterns.
- * In such a case a dummy query which returns no result is returned
- * (generate_query_for_empty_path_pattern()).
+ * A path pattern may end up producing no path if any of the element patterns
+ * yields no elements or the edge patterns yield no edges connecting adjacent
+ * vertex patterns.  In such a case a dummy query which returns no result is
+ * returned (generate_query_for_empty_path_pattern()).
  *
  * 'path_pattern' is given path pattern to be applied on the property graph in
  * the GRAPH_TABLE clause represented by given 'rte'.
@@ -503,9 +503,9 @@ generate_query_for_graph_path(RangeTblEntry *rte, List *graph_path)
 		 * SQL/PGQ standard (Ref. Section 11.19, Access rule 2 and General
 		 * rule 4) does not specify whose access privileges to use when
 		 * accessing the element tables: property graph owner's or current
-		 * user's. It is safer to use current user's privileges so as not to
-		 * make property graphs as a hole for unpriviledged data access. This
-		 * is inline with the views being security_invoker by default.
+		 * user's. It is safer to use current user's privileges to avoid
+		 * unprivileged data access through a property graph. This is inline
+		 * with the views being security_invoker by default.
 		 */
 		rel = table_open(pe->reloid, AccessShareLock);
 		pni = addRangeTableEntryForRelation(make_parsestate(NULL), rel, AccessShareLock,
-- 
2.34.1

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 24 Apr 2026 08:32:36 +0200

> I fixed some more typos and grammar in the attached patch. Also

committed