Subject: Re: [Bug] Add the missing RTE_GRAPH_TABLE case to transformLockingClause()

From: Ayush Tiwari <[email-masked]>
Date: Wed, 10 Jun 2026 01:03:45 +0530

Hi,

On Wed, 13 May 2026 at 10:57, Ashutosh Bapat <[email-masked]>
wrote:

> > Repro:
> >
> >   CREATE TABLE v(id int PRIMARY KEY, vname text);
> >   CREATE PROPERTY GRAPH g VERTEX TABLES (v);
> >   SELECT * FROM GRAPH_TABLE(g MATCH (a) COLUMNS (a.vname)) gt
> >     FOR UPDATE OF gt;
> >   -- ERROR:  unrecognized RTE type: 8
> >
> > Attached a patch that returns ERRCODE_FEATURE_NOT_SUPPORTED "FOR ...
> cannot be
> > applied to a GRAPH_TABLE" with a position pointer, matching the
> convention used by
> > the function/tablefunc etc.
>
> In a fully matured SQL/PGQ support, a row mark on GRAPH_TABLE should
> be pushed down to the resulting subqueries in rewriteGraphTable(). I
> see this similar to how the row mark is pushed down into views during
> the rewrite phase. I don't think the code changes will be massive, it
> will be a matter of invoking markQueryForLocking() on the query that
> replaces the graph pattern in rewriteGraphTable(). I am not sure
> whether we want to do that now when stabilizing the feature. Peter,
> what do you think?
>

I wanted to implement this by trying to push  FOR UPDATE/SHARE
down into the relational tables underlying the GRAPH_TABLE (the
"fully matured SQL/PGQ" direction mentioned). But had
some doubts around the implementation.

I'd like input on a few design questions from you/Peter/hackers:

  Q1. Is the right place to do the pushdown rewriteGraphTable(),
      mirroring what ApplyRetrieveRule() does for views (i.e. call
      markQueryForLocking() on the freshly built subquery)?  That
      would require exposing markQueryForLocking() outside
      rewriteHandler.c.

  Q2. How should FOR UPDATE behave when the MATCH expands to more
      than one path and rewriteGraphTable() produces a UNION?
      markQueryForLocking() refuses to descend into set-operations,
      same as it does for views.  Options:
        (a) reject FOR UPDATE on multi-path MATCH with a clear
            "cannot lock rows from a set-operation result" error,
            matching the view behaviour;
        (b) silently fall back to the current
            "raise relation lock only" behaviour and document it.
      I think it should be (a).

  Q3. SQL/PGQ does not really define UPDATE/DELETE semantics for
      graph paths.  Is the intent here that FOR UPDATE/SHARE on
      GRAPH_TABLE is purely a concurrency hint rather than a
      precursor to UPDATE WHERE CURRENT OF?  If so, that should
      probably be documented next to the GRAPH_TABLE syntax in
      the SQL reference.

> If we decide to not to support it, the code changes look on the right
> path. We need to update the following comment which appears earlier in
> the function to mention GRAPH_TABLE, /* ignore JOIN, SPECIAL,
> FUNCTION, VALUES, CTE RTEs */. I think it will be better to specify
> that this restriction is temporary in the comments at both the places;
> but that's arguable.
>
> > Patch includes tests for all four locking strengths.
> > Since the code path looks simple we can just keep one of them as well
> and trim other
> > tests. Thoughts?
>
> I don't think we need all the four tests, but we need a test for
> locking clause without relation since that takes a different code
> path.
>

Attached is v2-0001, rebased on master and addressing
the comments you added in case we plan on parking the feature
work for once v20 opens.

Regards,
Ayush

---

From: Ashutosh Bapat <[email-masked]>
Date: Wed, 10 Jun 2026 18:19:49 +0530

On Wed, Jun 10, 2026 at 1:03 AM Ayush Tiwari
<[email-masked]> wrote:
>
> Hi,
>
> On Wed, 13 May 2026 at 10:57, Ashutosh Bapat <[email-masked]> wrote:
>>
>> > Repro:
>> >
>> > Attached a patch that returns ERRCODE_FEATURE_NOT_SUPPORTED "FOR ... cannot be
>> > applied to a GRAPH_TABLE" with a position pointer, matching the convention used by

That's right. I think making markQueryForLocking non-static is fine
since we are using it in rewriter code itself.

>       I think it should be (a).

Building a UNION query is an implementation artifact of GRAPH_TABLE,
locking clause should not depend upon it. I think we should build the
subqueries within the setop with a locking clause of their own. That's
supported.

>       probably be documented next to the GRAPH_TABLE syntax in

I don't understand the WHERE CURRENT OF reference here. FOR
UPDATE/SHARE is generally used with an intent of locking the read rows
so that they don't get modified while the transaction is in progress.
One can use just UPDATE to update the FOR UPDATE locked rows as well.

>> > Since the code path looks simple we can just keep one of them as well and trim other
>> > tests. Thoughts?
>>

Thanks. I revised it a bit. Reworded the commit message to describe
user facing behaviour instead of the internals, which are quite
obvious from the code changes. Other cases in transformLockingClause()
don't mention XXX, they just have ereport(). Removed that comment.
Also massaged comments in the test - we usually don't describe the
expected behaviour or error when it is obvious from the output.
Attached revised patch.

-- 
Best Wishes,
Ashutosh Bapat
From a2f2bf2dadd670b3cdf452abced1cbbd4c99b373 Mon Sep 17 00:00:00 2001
From: Ayush Tiwari <[email-masked]>
Date: Tue, 9 Jun 2026 20:14:13 +0530
Subject: [PATCH v20260610 9/9] Prohibit Locking Clauses on GRAPH_TABLE

Specifying a locking clause (FOR UPDATE/SHARE) that names a GRAPH_TABLE
alias currently results in an unhelpful "unrecognized RTE type: 8"
error. This commit explicitly prohibits specifying a locking clause on a
GRAPH_TABLE alias, raising a more user-friendly "FOR ... cannot be
applied to a GRAPH_TABLE" error instead.

Author: SATYANARAYANA NARLAPURAM <[email-masked]>
Author: Ayush Tiwari <[email-masked]>
Reported-by: SATYANARAYANA NARLAPURAM <[email-masked]>
Reviewed-by: Ashutosh Bapat <[email-masked]>
Discussion: https://postgr.es/m/CAHg%2BQDcE9wp6nOEC3SCRQ90nrCO%3DQF%2BOZq1MG8Qc6hnusmogqw%40mail.gmail.com
---
 src/backend/parser/analyze.c              | 15 ++++++++++++++-
 src/test/regress/expected/graph_table.out | 13 +++++++++++++
 src/test/regress/sql/graph_table.sql      |  4 ++++
 3 files changed, 31 insertions(+), 1 deletion(-)

diff --git a/src/backend/parser/analyze.c b/src/backend/parser/analyze.c
index 93fa66ae57c..f762b653e77 100644
--- a/src/backend/parser/analyze.c
+++ b/src/backend/parser/analyze.c
@@ -3866,7 +3866,11 @@ transformLockingClause(ParseState *pstate, Query *qry, LockingClause *lc,
 										   allrels, true);
 					break;
 				default:
-					/* ignore JOIN, SPECIAL, FUNCTION, VALUES, CTE RTEs */
+
+					/*
+					 * ignore JOIN, SPECIAL, FUNCTION, VALUES, CTE,
+					 * GRAPH_TABLE
+					 */
 					break;
 			}
 		}
@@ -4001,6 +4005,15 @@ transformLockingClause(ParseState *pstate, Query *qry, LockingClause *lc,
 											LCS_asString(lc->strength)),
 									 parser_errposition(pstate, thisrel->location)));
 							break;
+						case RTE_GRAPH_TABLE:
+							ereport(ERROR,
+									(errcode(ERRCODE_FEATURE_NOT_SUPPORTED),
+							/*------
+							  translator: %s is a SQL row locking clause such as FOR UPDATE */
+									 errmsg("%s cannot be applied to a GRAPH_TABLE",
+											LCS_asString(lc->strength)),
+									 parser_errposition(pstate, thisrel->location)));
+							break;
 
 							/* Shouldn't be possible to see RTE_RESULT here */
 
diff --git a/src/test/regress/expected/graph_table.out b/src/test/regress/expected/graph_table.out
index c229212cb51..c0622ab7234 100644
--- a/src/test/regress/expected/graph_table.out
+++ b/src/test/regress/expected/graph_table.out
@@ -1129,4 +1129,17 @@ SELECT src.vname, count(*) FROM v1 AS src
  v13   |     1
 (3 rows)
 
+-- Locking clause on GRAPH_TABLE
+SELECT * FROM GRAPH_TABLE (g1 MATCH (src IS vl1) COLUMNS (src.vname)) gt FOR UPDATE OF gt;  -- not supported
+ERROR:  FOR UPDATE cannot be applied to a GRAPH_TABLE
+LINE 1: ...MATCH (src IS vl1) COLUMNS (src.vname)) gt FOR UPDATE OF gt;
+                                                                    ^
+SELECT * FROM GRAPH_TABLE (g1 MATCH (src IS vl1) COLUMNS (src.vname)) gt FOR UPDATE; -- ignored
+ vname 
+-------
+ v11
+ v12
+ v13
+(3 rows)
+
 -- leave the objects behind for pg_upgrade/pg_dump tests
diff --git a/src/test/regress/sql/graph_table.sql b/src/test/regress/sql/graph_table.sql
index e30c908dccc..437fb3b01f2 100644
--- a/src/test/regress/sql/graph_table.sql
+++ b/src/test/regress/sql/graph_table.sql
@@ -637,4 +637,8 @@ SELECT src.vname, count(*) FROM v1 AS src
   HAVING count(*) >= (SELECT count(*) FROM GRAPH_TABLE (g1 MATCH (a IS vl1 | vl2) COLUMNS (a.vname AS n)) WHERE n = src.vname)
   ORDER BY vname;
 
+-- Locking clause on GRAPH_TABLE
+SELECT * FROM GRAPH_TABLE (g1 MATCH (src IS vl1) COLUMNS (src.vname)) gt FOR UPDATE OF gt;  -- not supported
+SELECT * FROM GRAPH_TABLE (g1 MATCH (src IS vl1) COLUMNS (src.vname)) gt FOR UPDATE; -- ignored
+
 -- leave the objects behind for pg_upgrade/pg_dump tests
-- 
2.34.1

---

From: Peter Eisentraut <[email-masked]>
Date: Thu, 9 Jul 2026 10:18:53 +0200

> expected behaviour or error when it is obvious from the output.

Committed.

I also modified the comment that said "ignore JOIN, SPECIAL, ..." to 
just say "ignore all other RTE kinds", because keeping that kind of list 
up to date is silly.  (RTE_SPECIAL hasn't existed in a long time.)

---

From: Ashutosh Bapat <[email-masked]>
Date: Thu, 9 Jul 2026 15:10:48 +0530

> > expected behaviour or error when it is obvious from the output.

Thanks.

> up to date is silly.  (RTE_SPECIAL hasn't existed in a long time.)

That comment is useful since it confirms that the omission is
intentional; however I agree that keeping it up to date is cumbersome.
Maybe we need some way to tie the two switch cases so that
unintentional omissions can be easily caught.

-- 
Best Wishes,
Ashutosh Bapat