Subject: Add null check on get_tablespace_name() return in pg_get_database_ddl_internal

From: SATYANARAYANA NARLAPURAM <[email-masked]>
Date: Wed, 22 Apr 2026 15:20:36 -0700

Hi Hackers,

A concurrent tablespace drop could lead to null deref in
pg_get_database_ddl. I acknowledge this is a corner case. Adding a patch to
fix this to keep the code clean.

Thanks,
Satya

---

From: Chao Li <[email-masked]>
Date: Thu, 23 Apr 2026 08:03:08 +0800

> On Apr 23, 2026, at 06:20, SATYANARAYANA NARLAPURAM <[email-masked]> wrote:
> 
> Hi Hackers,
> 
> A concurrent tablespace drop could lead to null deref in pg_get_database_ddl. I acknowledge this is a corner case. Adding a patch to fix this to keep the code clean.
> 
> Thanks,
> Satya
> <0001-Fix-NULL-deref-in-pg_get_database_ddl-on-concurrent-tablespace-drop.patch>

This is a dup of my recent patch, see [1].

[1] https://www.postgresql.org/message-id/573E45C1-31A4-4885-A00C-1A2171159A2A%40gmail.com

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: SATYANARAYANA NARLAPURAM <[email-masked]>
Date: Wed, 22 Apr 2026 23:48:28 -0700

Hi Chao,

On Wed, Apr 22, 2026 at 5:03 PM Chao Li <[email-masked]> wrote:

> [1]
> https://www.postgresql.org/message-id/573E45C1-31A4-4885-A00C-1A2171159A2A%40gmail.com

Thanks, I replied there.