Subject: DOCS - DROP SUBSCRIPTION does not document parameter "IF EXISTS"

From: Peter Smith <[email-masked]>
Date: Wed, 1 Apr 2026 17:16:00 +1100

Hi.

I happened to notice that the "DROP PUBLICATION IF EXISTS" parameter
is documented [1]
------
IF EXISTS
Do not throw an error if the publication does not exist. A notice is
issued in this case.
------

But, the equivalent "DROP SUBSCRIPTION IF EXISTS" parameter
description is missing [2].

~~~

PSA a patch to add similar documentation for DROP SUBSCRIPTION IF EXISTS.

======
[1] https://www.postgresql.org/docs/devel/sql-droppublication.html
[2] https://www.postgresql.org/docs/devel/sql-dropsubscription.html

Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Chao Li <[email-masked]>
Date: Wed, 1 Apr 2026 14:43:15 +0800

> On Apr 1, 2026, at 14:16, Peter Smith <[email-masked]> wrote:
> 
> Hi.
> 
> <v1-0001-DOCS-Add-missing-description-for-DROP-SUBSCRIPTIO.patch>

Looks good. The patch uses the same phrase for “if exists” as the doc of “drop publication”. And I verified that a notice is issued:

```
evantest=# drop publication if exists aaa;
NOTICE:  publication "aaa" does not exist, skipping
DROP PUBLICATION
evantest=# drop subscription if exists aaa;
NOTICE:  subscription "aaa" does not exist, skipping
DROP SUBSCRIPTION
```

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 1 Apr 2026 09:11:35 -0500

On Wed, Apr 01, 2026 at 02:43:15PM +0800, Chao Li wrote:
> Looks good. The patch uses the same phrase for “if exists” as the doc of
> “drop publication”. And I verified that a notice is issued:

Thanks.  Will commit/back-patch shortly.

-- 
nathan

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 1 Apr 2026 09:54:23 -0500

> Thanks.  Will commit/back-patch shortly.

Done.

-- 
nathan

---

From: Peter Smith <[email-masked]>
Date: Thu, 2 Apr 2026 09:36:12 +1100

> > Thanks.  Will commit/back-patch shortly.

Thanks for pushing!

======
Kind Regards,
Peter Smith.
Fujitsu Australia