Subject: DOC: pg_publication_rel.prrelid says sequences are possible

From: Peter Smith <[email-masked]>
Date: Wed, 1 Apr 2026 15:59:54 +1100

Hi.

It is my understanding that only tables can exist in the
'pg_publication_rel' catalog.

e.g. only for these scenarios:
* included tables - when pg_publication.puballtables is false, these
are the specified FOR TABLE ... tables
* excluded tables - when pg_publication.puballtables is true, these
are the specified FOR ALL TABLES EXCEPT (TABLE ...) tables

In particular, AFAIK there is no way for sequences to be in the
'pg_publication_rel' catalog. e.g.
PG19 only supports "CREATE PUBLICATION ... FOR ALL SEQUENCES", which
is indicated by pg_publication.puballsequences.
PG19 has no support for "CREATE PUBLICATION ... FOR SEQUENCE seq1,seq2".

~~

Meanwhile, the DOCS page for 'pg_publication_rel' catalog [1] since
commit 55cefad says that sequences are also possible [2]:
------
prrelid oid (references pg_class.oid)
Reference to table or sequence
------

How are sequences possible? PSA a patch to correct it.

Or, am I mistaken here?

======
[1] https://www.postgresql.org/docs/devel/catalog-pg-publication-rel.html
[2] https://github.com/postgres/postgres/commit/55cefadde874e52b57f7b3c2232744e331f9d6bb#diff-686ae8747787a3c04698ca610350c2b7dc84618c5b28d4b90e94f6f8cd47bd8eR6571

Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: shveta malik <[email-masked]>
Date: Wed, 1 Apr 2026 12:35:34 +0530

> How are sequences possible? PSA a patch to correct it.

You are right, pg_publication_rel can never have a seq entry while
pg_subscription_rel can have. The patch LGTM.

thanks
Shveta

---

From: Amit Kapila <[email-masked]>
Date: Thu, 2 Apr 2026 14:03:09 +0530

> pg_subscription_rel can have. The patch LGTM.

Pushed.

-- 
With Regards,
Amit Kapila.

---

From: Peter Smith <[email-masked]>
Date: Tue, 7 Apr 2026 10:25:05 +1000

> On Wed, Apr 1, 2026 at 12:35 PM shveta malik <[email-masked]> wrote:
...
> > pg_subscription_rel can have. The patch LGTM.

Thanks for pushing.

======
Kind Regards,
Peter Smith.
Fujitsu Australia