public inbox for [email protected]  
help / color / mirror / Atom feed
From: Zsolt Parragi <[email protected]>
To: John Naylor <[email protected]>
Cc: PostgreSQL Hackers <[email protected]>
Cc: root <[email protected]>
Cc: Nathan Bossart <[email protected]>
Subject: Re: centralize CPU feature detection
Date: Wed, 18 Feb 2026 18:47:45 +0000
Message-ID: <CAN4CZFMrj1EB9fDQ4+8o-KzVRhh-FM5U3fXPSnc4YmU-LqNuPA@mail.gmail.com> (raw)
In-Reply-To: <CANWCAZYbTHwbt6PxPP_s0tWUZ_UMz_CcN2HMy0sWT+8TX7zSCA@mail.gmail.com>
References: <CANWCAZbgEUFw7LuYSVeJ=Tj98R5HoOB1Ffeqk3aLvbw5rU5NTw@mail.gmail.com>
	<CAN4CZFNpt2tsysM5j8GvhOLqU2fKiPEGW7xGJ987_Avwk7-7ag@mail.gmail.com>
	<CANWCAZbzmbCmKiCCWNGuC4FLymYfraJ+f1ZiWK3iOUnv9V9_Lg@mail.gmail.com>
	<CANWCAZYbTHwbt6PxPP_s0tWUZ_UMz_CcN2HMy0sWT+8TX7zSCA@mail.gmail.com>

> Done. I haven't tried Arm support yet, but now I realize the header
> should be named generically, so it's now "pg_cpu.h". Then it can be
> included everywhere.

That makes sense, and simplifies the usage of the header. (However,
the include guard still refers to the old name)

> I don't know. The instruction family names are conventionally all in
> caps, but this is just our signal that we've populated the array. That
> said, a less generic name would better for grep-ability.

Yes, that could work too. But reserving the lowercase "init" symbol in
a very generic header seems like a bad idea (especially for a use case
that isn't used globally), even if Postgres itself doesn't use the
symbol for anything else. "INIT" at least would be unlikely to
conflict with something else.






view thread (9+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected], [email protected], [email protected]
  Subject: Re: centralize CPU feature detection
  In-Reply-To: <CAN4CZFMrj1EB9fDQ4+8o-KzVRhh-FM5U3fXPSnc4YmU-LqNuPA@mail.gmail.com>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox