Subject: Re: Emitting JSON to file using COPY TO

From: Joe Conway <[email-masked]>
Date: Mon, 8 Jan 2024 15:40:23 -0500

On 1/8/24 14:36, Dean Rasheed wrote:
> On Thu, 7 Dec 2023 at 01:10, Joe Conway <[email-masked]> wrote:
>>
>> The attached should fix the CopyOut response to say one column.
>>
> 
> Playing around with this, I found a couple of cases that generate an error:
> 
> COPY (SELECT 1 UNION ALL SELECT 2) TO stdout WITH (format json);
> 
> COPY (VALUES (1), (2)) TO stdout WITH (format json);
> 
> both of those generate the following:
> 
> ERROR:  record type has not been registered

Thanks -- will have a look

-- 
Joe Conway
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com

---

From: "Andrey M. Borodin" <[email-masked]>
Date: Fri, 8 Mar 2024 22:28:04 +0500

Hello everyone!

Thanks for working on this, really nice feature!

> On 9 Jan 2024, at 01:40, Joe Conway <[email-masked]> wrote:
> 

Joe, recently folks proposed a lot of patches in this thread that seem like diverted from original way of implementation.
As an author of CF entry [0] can you please comment on which patch version needs review?

Thanks!

Best regards, Andrey Borodin.

[0] https://commitfest.postgresql.org/47/4716/

---

From: Joe Conway <[email-masked]>
Date: Fri, 8 Mar 2024 13:01:50 -0500

> As an author of CF entry [0] can you please comment on which patch version needs review?

I don't know if I agree with the proposed changes, but I have also been 
waiting to see how the parallel discussion regarding COPY extensibility 
shakes out.

And there were a couple of issues found that need to be tracked down.

Additionally I have had time/availability challenges recently.

Overall, chances seem slim that this will make it into 17, but I have 
not quite given up hope yet either.