Subject: Re: Psql meta-command conninfo+

From: Nathan Bossart <[email-masked]>
Date: Tue, 6 Feb 2024 15:06:05 -0600

On Tue, Feb 06, 2024 at 08:52:09PM +0000, Maiquel Grassi wrote:
> I made the adjustment in the code and updated the patch. I believe this
> is the format suggested by you all. Would this be it?

I was thinking something more like

  SELECT pg_catalog.current_database() AS "Database",
         current_user AS "User",
         pg_catalog.current_setting('server_version') AS "Server Version",
         pg_catalog.inet_server_addr() AS "Server Address",
         pg_catalog.current_setting('port') AS "Port",
         pg_catalog.inet_client_addr() AS "Client Address",
         pg_catalog.inet_client_port() AS "Client Port",
         pg_catalog.pg_backend_pid() AS "Session PID";

-- 
Nathan Bossart
Amazon Web Services: https://aws.amazon.com

---

From: Nathan Bossart <[email-masked]>
Date: Tue, 6 Feb 2024 15:12:05 -0600

>          pg_catalog.pg_backend_pid() AS "Session PID";

... although that seems to be missing items like the socket directory and
the host.

---

From: Maiquel Grassi <[email-masked]>
Date: Tue, 6 Feb 2024 21:39:20 +0000

--//--

Good, I had misunderstood. I liked this adjustment. Now it truly aligns with the central idea of the other extended meta-commands.

[postgres@localhost bin]$ ./psql -h 192.168.0.220 -p 5433 -U postgres -d postgres
psql (17devel, server 16.1)
Type "help" for help.

postgres=# \conninfo+
                                      Current Connection Information
 Database |   User   | Server Version | Server Address | Port | Client Address | Client Port | Session PID
----------+----------+----------------+----------------+------+----------------+-------------+-------------
 postgres | postgres | 16.1           | 192.168.0.220  | 5433 | 192.168.0.220  |       57112 |       22120
(1 row)

postgres=# \q
[postgres@localhost bin]$ ./psql
psql (17devel)
Type "help" for help.

postgres=# \conninfo+
                                      Current Connection Information
 Database |   User   | Server Version | Server Address | Port | Client Address | Client Port | Session PID
----------+----------+----------------+----------------+------+----------------+-------------+-------------
 postgres | postgres | 17devel        |                | 5432 |                |             |       31430
(1 row)

postgres=# \q
[postgres@localhost bin]$ ./psql -h localhost
psql (17devel)
Type "help" for help.

postgres=# \conninfo+
                                      Current Connection Information
 Database |   User   | Server Version | Server Address | Port | Client Address | Client Port | Session PID
----------+----------+----------------+----------------+------+----------------+-------------+-------------
 postgres | postgres | 17devel        | ::1            | 5432 | ::1            |       46918 |       31433
(1 row)

postgres=# \q
[postgres@localhost bin]$ ./psql -h 127.0.0.1
psql (17devel)
Type "help" for help.

postgres=# \conninfo+
                                      Current Connection Information
 Database |   User   | Server Version | Server Address | Port | Client Address | Client Port | Session PID
----------+----------+----------------+----------------+------+----------------+-------------+-------------
 postgres | postgres | 17devel        | 127.0.0.1      | 5432 | 127.0.0.1      |       34970 |       31435
(1 row)

Regards,
Maiquel O. Grassi.

---

From: Maiquel Grassi <[email-masked]>
Date: Tue, 6 Feb 2024 21:45:54 +0000

--//--

My initial idea has always been that they should continue to appear because \conninfo+ should show all the things that \conninfo shows and add more information. I think that's the purpose of the 'plus.' Now we're on a better path than the initial one. We can still add the socket directory and the host.

Regards,
Maiquel O. Grassi.