Subject: RE: AIX support

From: Srirama Kucherlapati <[email-masked]>
Date: Thu, 23 May 2024 15:36:24 +0000

Hi Peter, thanks for your feedback.

We are eager to extend our support in resolving the issues specific to AIX or corresponding
compilers (XLC and cLang).

But as there are no issues with the patch after reverting the changes(with the latest compilers
gcc12 and xlc-16.0.1.18), we were wondering if this patch can be merged with the current release 17??

Having said that, we are committed to resolve all the hacks and caveats that got
accumulated specific to AIX over the period by picking and resolving one after the other,
rather than waiting for all the hacks to be fixed.

 > One of the reasons that the AIX port ultimately became unmaintainable
  > was that so many hacks and caveats were accumulated over the years.  A
  > new port should set a more recent baseline and trim all those hacks.
Please help me understand this, with respect to the AIX specific hacks, is it just we can find
all the location where _AIX macros are involved OR can we just look at the patch changes only, as all
the changes that were made were specific to AIX. If not, is there any other location where
we could find all the hacks to be resolved.
Can you provide some more details on the expectations here?

Warm regards,
Sriram.

---

From: Heikki Linnakangas <[email-masked]>
Date: Thu, 23 May 2024 19:03:20 +0300

On 23/05/2024 18:36, Srirama Kucherlapati wrote:
> We are eager to extend our support in resolving the issues specific 
> to AIX or corresponding compilers (XLC and cLang).
> 
> But as there are no issues with the patch after reverting the 
> changes(with the latest compilers gcc12 and xlc-16.0.1.18), we were 
> wondering if this patch can be merged with the current release 17??
> 
> Having said that, we are committed to resolve all the hacks and 
> caveats that got accumulated specific to AIX over the period by 
> picking and resolving one after the other, rather than waiting for 
> all the hacks to be fixed.

I'm not eager to put back those hacks just to have them be removed
again. So I'd like to see a minimal patch, with the *minimal* changes
required for AIX support. And perhaps split that into two patches: First
add back AIX support with GCC, and second patch to add XLC support. I'd
like to to see how much of the changes are because of the different
compiler and how much from the OS.

No promises for v17, but if the patch is small and non-intrusive, I
would consider it at least. But let's see what it looks like first. It's
the same work that needs to be done whether it goes into v17 or v18 anyway.

>> One of the reasons that the AIX port ultimately became 
>> unmaintainable was that so many hacks and caveats were accumulated
>> over the years.  A new port should set a more recent baseline and
>> trim all those hacks.
> 
> Please help me understand this, with respect to the AIX specific 
> hacks, is it just we can find all the location where _AIX macros are 
> involved OR can we just look at the patch changes only, as all the 
> changes that were made were specific to AIX. If not, is there any 
> other location where we could find all the hacks to be resolved.
> 

Smallest possible patch that makes Postgres work on AIX again.

Perhaps start with the patch you posted yesterday, but remove hunks from 
it one by one, to see which ones are still needed.

-- 
Heikki Linnakangas
Neon (https://neon.tech)

---

From: Bruce Momjian <[email-masked]>
Date: Sun, 26 May 2024 00:00:33 -0400

On Thu, May 23, 2024 at 07:03:20PM +0300, Heikki Linnakangas wrote:
> Perhaps start with the patch you posted yesterday, but remove hunks from it
> one by one, to see which ones are still needed.

Yes, bingo, that is exactly what needs to be done, and for the minimal
compiler, gcc, and the most recently supported versions of AIX.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: Srirama Kucherlapati <[email-masked]>
Date: Fri, 7 Jun 2024 16:30:35 +0000

Hi Team, We are pursuing to trim the changes wrt AIX. As of now we trimmed
the changes with respect to XLC and currently with trimmed changes the
buildfarm script passed (build and all the regression tests)
The XLC changes were trimmed only in the below file
    modified: configure
    modified: configure.ac
We are looking further into the other file changes as well.

Warm regards,
Sriram.

---

From: Laurenz Albe <[email-masked]>
Date: Mon, 10 Jun 2024 11:30:06 +0200

> The XLC changes were trimmed only in the below file

Did you forget an attachment?

Yours,
Laurenz Albe

---

From: Srirama Kucherlapati <[email-masked]>
Date: Tue, 11 Jun 2024 11:38:14 +0000

Hi Laurenz, we are working on the other file changes, we shall post you the updates soon.
Warm regards,
Sriram.

---

From: Srirama Kucherlapati <[email-masked]>
Date: Wed, 19 Jun 2024 14:55:47 +0000

Hi Team,
Please find the attached patch, which resumes the AIX support with gcc alone. We have
removed changes wrt to XLC on AIX.

We are also continuing to work on the XLC and IBM-clang(openXLC) specific patch as well.
Once we get an approval for the above patch we can submit a subsequent patch to support
XLC/IBM-clang changes.

Kindly let us know your inputs/feedback.

Warm regards,
Sriram.