Subject: [16Beta1][doc] pgstat: Track time of the last scan of a relation

From: "Shinoda, Noriyoshi (PN Japan FSIP)" <[email-masked]>
Date: Wed, 31 May 2023 03:56:51 +0000

Hi, hackers.
 PostgreSQL 16 Beta1, added last access time to pg_stat_all_tables and pg_stat_all_indexes views by this patch [1].
According to the documentation [2], the data type of the columns added to these views is 'timestamptz'. 
However, columns of the same data type in pg_stat_all_tables.last_vacuum, last_analyze and other tables are unified to 'timestamp with time zone'. The attached patch changes the data type of the added column from timestamptz to timestamp with time zone.

[1] pgstat: Track time of the last scan of a relation
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=c037471832e1ec3327f81eebbd8892e5c1042fe0
[2] pg_stat_activity view
https://www.postgresql.org/docs/16/monitoring-stats.html#MONITORING-PG-STAT-ALL-TABLES-VIEW

Regards,
Noriyoshi Shinoda

---

From: David Rowley <[email-masked]>
Date: Wed, 31 May 2023 18:13:57 +1200

> However, columns of the same data type in pg_stat_all_tables.last_vacuum, last_analyze and other tables are unified to 'timestamp with time zone'. The attached patch changes the data type of the ad…

I agree that it would be good to make those consistently use timestamp
with time zone for all columns of that type in the docs for
pg_stat_all_tables.

More generally, it might be good if we did it for the entire docs:

doc $ git grep "<type>timestamptz</type>" | wc -l
17
doc $ git grep "<type>timestamp with time zone</type>" | wc -l
74

Clearly "timestamp with time zone" is much more commonly used.

The bar is probably set a bit higher for changing the
longer-established ones, however.

David

---

From: "Shinoda, Noriyoshi (PN Japan FSIP)" <[email-masked]>
Date: Thu, 1 Jun 2023 09:38:18 +0000

Hi, Thanks for your comment.
As you say, it would be difficult to unify the data types in all documents right now.
The patch I attached the other day unifies only the newly added columns in monitoring.sgml to "timestamp with time zone".

Regards,
Noriyoshi Shinoda
-----Original Message-----
From: David Rowley <[email-masked]> 
Sent: Wednesday, May 31, 2023 3:14 PM
To: Shinoda, Noriyoshi (PN Japan FSIP) <[email-masked]>
Cc: PostgreSQL-development <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [16Beta1][doc] pgstat: Track time of the last scan of a relation

> However, columns of the same data type in pg_stat_all_tables.last_vacuum, last_analyze and other tables are unified to 'timestamp with time zone'. The attached patch changes the data type of the ad…

I agree that it would be good to make those consistently use timestamp with time zone for all columns of that type in the docs for pg_stat_all_tables.

The bar is probably set a bit higher for changing the longer-established ones, however.

David

---

From: David Rowley <[email-masked]>
Date: Mon, 5 Jun 2023 17:36:52 +1200

> However, columns of the same data type in pg_stat_all_tables.last_vacuum, last_analyze and other tables are unified to 'timestamp with time zone'. The attached patch changes the data type of the ad…

I've now pushed this change.

David