Subject: Fix Grammar in Buffer Lock Wait Message

From: Guoqing Yang <[email-masked]>
Date: Wed, 1 Jul 2026 09:44:53 +0800

Fix grammar in buffer lock wait message

Correct the wait message from "Waiting to acquire a exclusive lock on a 
buffer"
to "Waiting to acquire an exclusive lock on a buffer".

The word "exclusive" starts with a vowel sound, so the indefinite article
should be "an" instead of "a".

Regards,
Guoqing Yang

diff --git a/src/backend/utils/activity/wait_event_names.txt b/src/backend/utils/activity/wait_event_names.txt
index 560659f9568..bafdd7d2e96 100644
--- a/src/backend/utils/activity/wait_event_names.txt
+++ b/src/backend/utils/activity/wait_event_names.txt
@@ -294,7 +294,7 @@ Section: ClassName - WaitEventBuffer
 BUFFER_CLEANUP "Waiting to acquire an exclusive pin on a buffer. Buffer pin waits can be protracted if another process holds an open cursor that last read data from the buffer in question."
 BUFFER_SHARED  "Waiting to acquire a shared lock on a buffer."
 BUFFER_SHARE_EXCLUSIVE "Waiting to acquire a share exclusive lock on a buffer."
-BUFFER_EXCLUSIVE       "Waiting to acquire a exclusive lock on a buffer."
+BUFFER_EXCLUSIVE       "Waiting to acquire an exclusive lock on a buffer."

 ABI_compatibility:

---

From: Chao Li <[email-masked]>
Date: Wed, 1 Jul 2026 10:02:34 +0800

> On Jul 1, 2026, at 09:44, Guoqing Yang <[email-masked]> wrote:
> 
> Correct the wait message from "Waiting to acquire a exclusive lock on a buffer"

Nice catch.

The typo is in wait_event_names.txt, so it actually affects the docs. See the attached doc screenshot.
```
BufferCleanup Waiting to acquire **an exclusive** pin on a buffer. Buffer pin waits can be
BufferExclusive Waiting to acquire **a exclusive** lock on a buffer. 
```

The row right above it uses “an exclusive”, while the next row uses “a exclusive”.

This seems to be an oversight from 6c5c393b7, so I think it should be back-patched to 19.

Best regards,*
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/