Subject: Re: [PATCH] Fix Potential Memory Leak in pg_amcheck Code

From: Kirill Reshke <[email-masked]>
Date: Sun, 23 Feb 2025 11:49:05 +0500

Hi!

On Fri, 7 Feb 2025 at 13:28, Daniel Gustafsson <[email-masked]> wrote:
>
> That being said, there is
> value in doing the right thing and setting good examples in our own code as
> many do read it and reference it.

> We call PQclear on such a
> case elsewhere in the file so it's not entirely consistent, but it's not all
> that important as the memory will be reclaimed at exit.

So, are we +1 or -1 on moving this forward?

-- 
Best regards,
Kirill Reshke

---

From: Jelte Fennema-Nio <[email-masked]>
Date: Sun, 23 Feb 2025 13:02:35 +0100

> So, are we +1 or -1 on moving this forward?

+1 from me. Marked as ready for committer.

---

From: Daniel Gustafsson <[email-masked]>
Date: Sun, 23 Feb 2025 13:24:48 +0100

> On 23 Feb 2025, at 13:03, Jelte Fennema-Nio <[email-masked]> wrote:
> 

Agreed, I have it on my TODO for the week to revisit.

./daniel