Subject: Re: DOCS - Add introductory paragraph to Getting Started chapter

From: "David G. Johnston" <[email-masked]>
Date: Thu, 19 Feb 2026 09:14:45 -0700

On Thu, Feb 19, 2026 at 6:51 AM Philip Alger <[email-masked]> wrote:

>
>
> On Thu, Feb 19, 2026 at 3:58 AM Dragos Andriciuc <
> [email-masked]> wrote:
>
>> Thanks for pointing that out. The intention was to add two paragraphs and
>> it is now corrected to use
>> two separate <para> tags. Attached is v2 of the patch.
>>
>> I have verified that the docs build and render correctly in HTML locally.
>>
>>>
>>>
> Hello,
>
> It's always good to add more documentation. I wouldn't consider two single
> sentences as separate paragraphs though.
>
> However, I think these sentences can be combined into one.
>
> For example:
>
> This chapter provides a practical introduction to
> <productname>PostgreSQL</productname>
> by guiding you through software installation, basic architectural
> concepts, and how to create and access
> your first database.
>
> I think this version combines the two essentially.
>
>
All that does is put the existing Table of Contents into paragraph form.
I'd keep the second sentence and let the ToC speak for itself personally.
Or put a bit more effort into saying something about those topics that a
ToC header cannot convey.  I'm fine with the status quo though, at least
compared to the proposed.

Probably should make 'server', 'client' and 'database' links to the
glossary - though the architecture page will also provide detail if they
perform a linear read.

Looking at this more critically, why does installation come before
architecture?  I would expect architecture to include information that
improves understanding what is being installed and why.  Or, more
generally, theory before practice.

Suggestion:
<para>
[First] This chapter provides a brief introduction to the concepts and
terminology employed in PostgreSQL's design.  [Then] It also walks you
through getting a server and client installed on your machine and ensuring
it is functioning by creating a new database and connecting to it via the
command line client.
</para>

David J.

---

From: Dragos Andriciuc <[email-masked]>
Date: Thu, 19 Feb 2026 17:04:43 +0000

Hello,

The chapter currently opens directly with a list of subsections and no introductory text.

This differs from the structure used in other chapters, but I understand the preference for avoiding redundancy with the ToC.

I've revised the introduction to simplify the structure and avoid restating the table of contents too directly, merging the two sentences into one.

Attached is v3.

________________________________
From: David G. Johnston <[email-masked]>
Sent: Thursday, February 19, 2026 6:14 PM
To: Philip Alger <[email-masked]>
Cc: Dragos Andriciuc <[email-masked]>; Andreas Karlsson <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: DOCS - Add introductory paragraph to Getting Started chapter

On Thu, Feb 19, 2026 at 6:51 AM Philip Alger <[email-masked]<mailto:[email-masked]>> wrote:

On Thu, Feb 19, 2026 at 3:58 AM Dragos Andriciuc <[email-masked]<mailto:[email-masked]>> wrote:
Thanks for pointing that out. The intention was to add two paragraphs and it is now corrected to use
two separate <para> tags. Attached is v2 of the patch.

Hello,

It's always good to add more documentation. I wouldn't consider two single sentences as separate paragraphs though.

For example:

This chapter provides a practical introduction to <productname>PostgreSQL</productname>
by guiding you through software installation, basic architectural concepts, and how to create and access
your first database.

All that does is put the existing Table of Contents into paragraph form.  I'd keep the second sentence and let the ToC speak for itself personally.  Or put a bit more effort into saying something about those topics that a ToC header cannot convey.  I'm fine with the status quo though, at least compared to the proposed.

Probably should make 'server', 'client' and 'database' links to the glossary - though the architecture page will also provide detail if they perform a linear read.

Looking at this more critically, why does installation come before architecture?  I would expect architecture to include information that improves understanding what is being installed and why.  Or, more generally, theory before practice.

Suggestion:
<para>
[First] This chapter provides a brief introduction to the concepts and terminology employed in PostgreSQL's design.  [Then] It also walks you through getting a server and client installed on your machine and ensuring it is functioning by creating a new database and connecting to it via the command line client.
</para>

David J.

---

From: Chao Li <[email-masked]>
Date: Thu, 26 Feb 2026 16:48:25 +0800

> On Feb 20, 2026, at 01:04, Dragos Andriciuc <[email-masked]> wrote:
> 
> Hello,
> 
> On Thu, Feb 19, 2026 at 3:58 AM Dragos Andriciuc <[email-masked]> wrote:
> <v3-0001-Add-introductory-paragraph-to-Getting-Started-chapter.patch>

V3 seems very polished. I agree the new paragraph is a helpful improvement for new doc readers.

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: "David G. Johnston" <[email-masked]>
Date: Fri, 27 Feb 2026 09:28:02 -0700

> V3 seems very polished. I agree the new paragraph is a helpful improvement
Works for me.

David J.

---

From: Dragos Andriciuc <[email-masked]>
Date: Wed, 22 Apr 2026 09:45:49 +0000

Hello Tom,
Thank you for the review, I agree with you.
For this patch, I focused on Chapter 1 to improve the initial onboarding experience, but you’re right that Chapters 2 and 3 would benefit from introductory paragraphs as well.
I will address these in a follow up update to keep the structure consistent and intact in the tutorial.
I appreciate the feedback.
Best regards,
Dragos

________________________________
From: Tom Lane <[email-masked]>
Sent: Thursday, March 26, 2026 8:14 PM
To: David G. Johnston <[email-masked]>
Cc: Chao Li <[email-masked]>; Dragos Andriciuc <[email-masked]>; Philip Alger <[email-masked]>; Andreas Karlsson <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: DOCS - Add introductory paragraph to Getting Started chapter

> Works for me.

I have no particular objection to this patch, but I wonder why it
only addresses the tutorial's Chapter 1.  Chapters 2 and 3 likewise
lack any introductory paragraph.

                        regards, tom lane