Subject: Remove wal_level settings for subscribers in tap tests

From: "Hayato Kuroda (Fujitsu)" <[email-masked]>
Date: Wed, 18 Oct 2023 02:59:52 +0000

Dear hackers,

While discussing [1], I found that in tap tests, wal_level was set to logical for
subscribers too. The setting is not needed for subscriber side, and it may cause
misunderstanding for newcomers. Therefore, I wanted to propose the patch which
removes unnecessary "allows_streaming => 'logical'".
I grepped with the string and checked the necessity of them one by one.

How do you think?

[1]: https://commitfest.postgresql.org/45/4273/

Best Regards,
Hayato Kuroda
FUJITSU LIMITED

---

From: Michael Paquier <[email-masked]>
Date: Wed, 18 Oct 2023 15:39:16 +0900

> [1]: https://commitfest.postgresql.org/45/4273/

Hmm, okay.  On top of your argument, this may be a good idea for a
different reason: it makes the tests a bit cheaper as "logical"
generates a bit more WAL.  Still the gain is marginal. 
--
Michael