Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1lRZGO-0002g5-2s for pgsql-hackers@arkaria.postgresql.org; Wed, 31 Mar 2021 11:43:56 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1lRZGL-0005mN-Vj for pgsql-hackers@arkaria.postgresql.org; Wed, 31 Mar 2021 11:43:53 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1lRZGL-0005mF-PA for pgsql-hackers@lists.postgresql.org; Wed, 31 Mar 2021 11:43:53 +0000 Received: from feynman.df7cb.de ([195.49.152.168]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1lRZGI-0001L2-Qj for pgsql-hackers@postgresql.org; Wed, 31 Mar 2021 11:43:53 +0000 Received: from msg.df7cb.de (unknown [IPv6:2a02:908:1478:7c00:76e5:bff:fef3:7e00]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-256) server-signature ECDSA (P-384) server-digest SHA384) (Client did not present a certificate) by feynman.df7cb.de (Postfix) with ESMTPSA id 4F9PbR5kt0z3DwS; Wed, 31 Mar 2021 13:43:47 +0200 (CEST) Date: Wed, 31 Mar 2021 13:43:47 +0200 From: Christoph Berg To: Kyotaro Horiguchi Cc: pgsql-hackers@postgresql.org Subject: Re: "box" type description Message-ID: Mail-Followup-To: Christoph Berg , Kyotaro Horiguchi , pgsql-hackers@postgresql.org References: <20210331.113240.1063412187478637420.horikyota.ntt@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20210331.113240.1063412187478637420.horikyota.ntt@gmail.com> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Re: Kyotaro Horiguchi > Returing to the description of pg_types, it should be changed like > this following the discussion here. > > - pg_catalog | box | geometric box '(lower left,upper right)' > + pg_catalog | box | geometric box 'lower left,upper right' > > But I find it hard to read. I fixed it instead as the following in the > attached. However, it might rather be better not changing it.. > > + pg_catalog | box | geometric box 'pt-lower-left,pt-upper-right' I like that because it points to the "point" syntax so users can figure out how to spell a box. Christoph