Subject: Re: typos

From: Alvaro Herrera <[email-masked]>
Date: Wed, 20 Apr 2022 23:32:08 +0200

On 2022-Apr-19, Alvaro Herrera wrote:

> I propose we standardize on <productname>Zstd</productname> everywhere.
> Users can look it up if they're really interested.

So the attached.

There are other uses of <literal>zstd</literal>, but those are referring to the
executable program.

-- 
Álvaro Herrera         PostgreSQL Developer  —  https://www.EnterpriseDB.com/
"No necesitamos banderas
 No reconocemos fronteras"                  (Jorge González)
>From 256904cc5a8718ac081dbf51f6263ab022e503f6 Mon Sep 17 00:00:00 2001
From: Alvaro Herrera <[email-masked]>
Date: Wed, 20 Apr 2022 23:26:28 +0200
Subject: [PATCH] Zstd

---
 doc/src/sgml/install-windows.sgml | 6 +++---
 doc/src/sgml/installation.sgml    | 4 ++--
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/doc/src/sgml/install-windows.sgml b/doc/src/sgml/install-windows.sgml
index 43cc5f6f5b..104670d295 100644
--- a/doc/src/sgml/install-windows.sgml
+++ b/doc/src/sgml/install-windows.sgml
@@ -307,9 +307,9 @@ $ENV{MSBFLAGS}="/m";
     </varlistentry>
 
     <varlistentry>
-     <term><productname>ZSTD</productname></term>
+     <term><productname>Zstd</productname></term>
      <listitem><para>
-      Required for supporting <productname>ZSTD</productname> compression
+      Required for supporting <productname>Zstd</productname> compression
       method. Binaries and source can be downloaded from
       <ulink url="https://github.com/facebook/zstd/releases"></ulink>.
      </para></listitem>
@@ -560,7 +560,7 @@ $ENV{PROVE_TESTS}='t/020*.pl t/010*.pl'
     <varlistentry>
      <term><varname>ZSTD</varname></term>
      <listitem><para>
-      Path to a <application>zstd</application> command. The default is
+      Path to a <application>Zstd</application> command. The default is
       <literal>zstd</literal>, which will search for a command by that
       name in the configured <envar>PATH</envar>.
      </para></listitem>
diff --git a/doc/src/sgml/installation.sgml b/doc/src/sgml/installation.sgml
index df32025a86..c60484e221 100644
--- a/doc/src/sgml/installation.sgml
+++ b/doc/src/sgml/installation.sgml
@@ -273,7 +273,7 @@ su - postgres
 
     <listitem>
      <para>
-      You need <productname>zstd</productname>, if you want to support
+      You need <productname>Zstd</productname>, if you want to support
       compression of data with that method; see
       <xref linkend="guc-wal-compression"/>.
       The minimum required version is 1.4.0.
@@ -996,7 +996,7 @@ build-postgresql:
        <term><option>--with-zstd</option></term>
        <listitem>
         <para>
-         Build with <productname>ZSTD</productname> compression support.
+         Build with <productname>Zstd</productname> compression support.
         </para>
        </listitem>
       </varlistentry>
-- 
2.30.2

---

From: Justin Pryzby <[email-masked]>
Date: Wed, 20 Apr 2022 16:38:42 -0500

> There are other uses of <literal>zstd</literal>, but those are referring to the

This one shouldn't be changed, or not like this?

>        name in the configured <envar>PATH</envar>.

Maybe it should say s/a/the/, like:

-      Path to a <application>zstd</application> command. The default is
+      Path to the <application>zstd</application> command. The default is

---

From: Michael Paquier <[email-masked]>
Date: Thu, 21 Apr 2022 13:36:29 +0900

> +      Required for supporting <productname>Zstd</productname> compression

Looking at the zstd project itself for reference or just wiki-sensei,
I don't think that this is correct:
https://github.com/facebook/zstd
https://en.wikipedia.org/wiki/Zstd

Their README uses "zstd" in lower-case, while "Zstd" (first letter
upper-case) is used at the beginning of a sentence.
--
Michael

---

From: Peter Eisentraut <[email-masked]>
Date: Thu, 21 Apr 2022 15:59:49 +0200

> upper-case) is used at the beginning of a sentence.

It is referred to as "Zstandard" at both of those places.  Maybe we 
should use that.  That is also easier to pronounce.

---

From: Justin Pryzby <[email-masked]>
Date: Tue, 10 May 2022 21:03:34 -0500

I found a bunch more typos; a couple from codespell, and several which are the
result of looking for previously-reported typos, like:

time git log origin --grep '[tT]ypo' --word-diff -U1 |grep -Eo '\[-[[:lower:]]+-\]' |sed 's/^\[-//; s/-\]$//' |sort -u |grep -Fxvwf /usr/share/dict/words >badwords.txt
time grep -rhoFwf badwords.txt doc |sort -u >not-badwords.txt
time grep -Fxvwf not-badwords.txt ./badwords.txt >./badwords.txt.new
time grep -rhoIFwf ./badwords.txt.new src --incl='*.[chly]' --incl='*.p[lm]' |sort |uniq -c |sort -nr |less

---

From: Michael Paquier <[email-masked]>
Date: Wed, 11 May 2022 15:41:27 +0900

> result of looking for previously-reported typos, like:

Thanks, applied 0002.

Regarding 0001, I don't really know which one of {AND,OR}ed or
{AND,OR}-ed is better.  Note that the code prefers the former, but
your patch changes the docs to use the latter.
--
Michael