Subject: Subscription suborigin?

From: Bruce Momjian <[email-masked]>
Date: Wed, 10 May 2023 15:36:31 -0400

This commit:

	commit 366283961a
	Author: Amit Kapila <[email-masked]>
	Date:   Thu Jul 21 08:47:38 2022 +0530
	
	    Allow users to skip logical replication of data having origin.

has this change:

	diff --git a/doc/src/sgml/catalogs.sgml b/doc/src/sgml/catalogs.sgml
	index 670a5406d6..a186e35f00 100644
	--- a/doc/src/sgml/catalogs.sgml
	+++ b/doc/src/sgml/catalogs.sgml
	@@ -7943,6 +7943,20 @@ SCRAM-SHA-256$<replaceable>&lt;iteration count&gt;</replaceable>:<replaceable>&l
	        see <xref linkend="logical-replication-publication"/>.
	       </para></entry>
	      </row>
	+
	+     <row>
	+      <entry role="catalog_table_entry"><para role="column_definition">
-->	+       <structfield>suborigin</structfield> <type>text</type>
	+      </para>
	+      <para>
-->	+       The origin value must be either <literal>none</literal> or
	+       <literal>any</literal>. The default is <literal>any</literal>.
	+       If <literal>none</literal>, the subscription will request the publisher
	+       to only send changes that don't have an origin. If
	+       <literal>any</literal>, the publisher sends changes regardless of their
	+       origin.
	+      </para></entry>
	+     </row>
	     </tbody>
	    </tgroup>
	   </table>

Is 'suborigin' the right column mame, and if so, should "The origin
value" be "The suborigin value"?

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Embrace your flaws.  They make you human, rather than perfect,
  which you will never be.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 10 May 2023 15:37:24 -0400

Never mind --- I just realized "sub" is the table prefix.  :-(

---------------------------------------------------------------------------