public inbox for [email protected]
help / color / mirror / Atom feedFrom: Michael Paquier <[email protected]>
To: Dagfinn Ilmari Mannsåker <[email protected]>
Cc: vignesh C <[email protected]>
Cc: PostgreSQL Hackers <[email protected]>
Subject: Re: Implement generalized sub routine find_in_log for tap test
Date: Fri, 26 May 2023 07:39:17 +0900
Message-ID: <ZG/[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <CALDaNm0YSiLpjCmajwLfidQrFOrLNKPQir7s__PeVvh9U3uoTQ@mail.gmail.com>
<[email protected]>
On Thu, May 25, 2023 at 06:34:20PM +0100, Dagfinn Ilmari Mannsåker wrote:
> However, none of the other functions in ::Utils know anything about node
> objects, which makes me think it should be a method on the node itself
> (i.e. in PostgreSQL::Test::Cluster) instead. Also, I think log_contains
> would be a better name, since it just returns a boolean. The name
> find_in_log makes me think it would return the log lines matching the
> pattern, or the position of the match in the file.
>
> In that case, the slurp_file() call would have to be fully qualified,
> since ::Cluster uses an empty import list to avoid polluting the method
> namespace with imported functions.
Hmm. connect_ok() and connect_fails() in Cluster.pm have a similar
log comparison logic, feeding from the offset of a log file. Couldn't
you use the same code across the board for everything? Note that this
stuff is parameterized so as it is possible to check if patterns match
or do not match, for multiple patterns. It seems to me that we could
use the new log finding routine there as well, so how about extending
it a bit more? You would need, at least:
- One parameter for log entries matching.
- One parameter for log entries not matching.
--
Michael
Attachments:
[application/pgp-signature] signature.asc (833B, ../ZG%[email protected]/2-signature.asc)
download
view thread (5+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected]
Subject: Re: Implement generalized sub routine find_in_log for tap test
In-Reply-To: <ZG/[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox