Subject: Re: Fix incorrect comment reference

From: James Coleman <[email-masked]>
Date: Mon, 23 Jan 2023 15:19:14 -0500

On Mon, Jan 23, 2023 at 1:26 PM Robert Haas <[email-masked]> wrote:
>
> On Mon, Jan 23, 2023 at 8:31 AM James Coleman <[email-masked]> wrote:
> > See the attached for a simple comment fix -- the referenced
> > generate_useful_gather_paths call isn't in grouping_planner it's in
> > apply_scanjoin_target_to_paths.
>
> The intended reading of the comment is not clear. Is it telling you to
> look at grouping_planner because that's where we
> generate_useful_gather_paths, or is it telling you to look there to
> see how we get the final target list together? If it's the former,
> then your fix is correct. If the latter, it's fine as it is.
>
> The real answer is probably that some years ago both things happened
> in that function. We've moved on from there, but I'm still not sure
> what the most useful phrasing of the comment is.

Yeah, almost certainly, and the comments just didn't keep up.

Would you prefer something that notes both that the broader concern is
happening via the grouping_planner() stage but still points to the
proper callsite (so that people don't go looking for that confused)?

James Coleman

---

From: Robert Haas <[email-masked]>
Date: Mon, 23 Jan 2023 15:41:45 -0500

> proper callsite (so that people don't go looking for that confused)?

I don't really have a strong view on what the best thing to do is. I
was just pointing out that the comment might not be quite so obviously
wrong as you were supposing.

-- 
Robert Haas
EDB: http://www.enterprisedb.com

---

From: James Coleman <[email-masked]>
Date: Mon, 23 Jan 2023 16:07:03 -0500

> wrong as you were supposing.

"Wrong" is certainly too strong; my apologies.

I'm really just hoping to improve it for future readers to save them
some confusion I had initially reading it.

James Coleman

---

From: James Coleman <[email-masked]>
Date: Mon, 23 Jan 2023 18:42:45 -0500

> some confusion I had initially reading it.

Updated patch attached.

Thanks,
James Coleman

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 29 Sep 2023 14:26:19 -0400

> > some confusion I had initially reading it.

Patch applied.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: James Coleman <[email-masked]>
Date: Fri, 29 Sep 2023 14:38:39 -0400

> > > some confusion I had initially reading it.

Thanks!

Regards,
James Coleman