Subject: Re: Typos in the code and README

From: David Rowley <[email-masked]>
Date: Fri, 12 Apr 2024 01:29:58 +1200

On Fri, 12 Apr 2024, 1:05 am Daniel Gustafsson, <[email-masked]> wrote:

> Now that the tree has settled down a bit post-freeze I ran some tooling to
> check spelling.  I was primarily interested in docs and README* which were
> mostly free from simply typos, while the code had some in various comments
> and
> one in code.  The attached fixes all that I came across (not
> cross-referenced
> against ongoing reverts or any other fixup threads but will be before
> pushing
> of course).
>

I see you've corrected "iif" to "if". It should be "iff".

David

---

From: Daniel Gustafsson <[email-masked]>
Date: Thu, 11 Apr 2024 15:37:00 +0200

> On 11 Apr 2024, at 15:29, David Rowley <[email-masked]> wrote:
> 
> On Fri, 12 Apr 2024, 1:05 am Daniel Gustafsson, <[email-masked] <mailto:[email-masked]>> wrote:
>> mostly free from simply typos, while the code had some in various comments and
>> one in code.  The attached fixes all that I came across (not cross-referenced
>> against ongoing reverts or any other fixup threads but will be before pushing
>> of course).
> 
> 

Gotcha, will fix.  I opted for "if" due to recent threads where the use of
"iff" was discouraged due to not being commonly known, but that was in doc/ and
not code comments.

--
Daniel Gustafsson

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 12 Apr 2024 16:55:16 -0400

> "iff" was discouraged due to not being commonly known, but that was in doc/ and

I actually agree "iff" is just not clear enough.  "Iff" stands for "if
and only if" and maybe should be spelled out that way.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 12 Apr 2024 16:58:22 -0400

> and only if" and maybe should be spelled out that way.

Just to clarify, I think "if and only if" means "if A then B" and B can
only happen if A happens, meaning there are not other cases where B can
happen.  This latter part is what disinguishes "iff" from "if".