Subject: src/backend/optimizer/util/plancat.c -> Is this correct English

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Wed, 25 Sep 2024 16:52:47 +0000

Hi,

just came across this:

src/backend/optimizer/util/plancat.c -> Is this correct English?
-> We need not lock the relation since it was already locked ... 

I am not a native speaker, but this sounds strange.

Regards
Daniel?

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 25 Sep 2024 11:59:04 -0500

> I am not a native speaker, but this sounds strange.

I think it's fine.  It could also be phrased like this:

	We do not need to lock the relation since...

-- 
nathan

---

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Wed, 25 Sep 2024 17:35:48 +0000

>        We do not need to lock the relation since...

That's what I would have expected. But, as said, maybe this only sounds strange to me.

Regards
Daniel

---

From: Tom Lane <[email-masked]>
Date: Wed, 25 Sep 2024 13:50:30 -0400

> That's what I would have expected. But, as said, maybe this only sounds strange to me.

"Need not" is perfectly good English, although perhaps it has a
faintly archaic whiff to it.

			regards, tom lane