Subject: Re: Missing installation of Kerberos.pm and AdjustUpgrade.pm

From: Michael Paquier <[email-masked]>
Date: Thu, 24 Oct 2024 14:51:05 +0900

On Tue, Jul 09, 2024 at 04:46:23PM +0900, Michael Paquier wrote:
> I cannot say much in favor of Kerberos.pm, but AdjustUpgrade.pm could
> be really useful IMO when running the main regression test suite in an
> out-of-core module for upgrade scenarios.  Not to mention that it
> includes a set of filtering regexes that are rather generic.

While catching up with some other thing, I've been reminded that this
has not been addressed.  Any objections if I were to apply the
attached to add install and uninstall rules for Kerberos.pm and
AdjustUpgrade.pm?

If people would prefer a backpatch, please let me know.
--
Michael
From a2465b3dcb3eb22fa5f6d55a6823accd85e8683a Mon Sep 17 00:00:00 2001
From: Michael Paquier <[email-masked]>
Date: Thu, 24 Oct 2024 14:41:39 +0900
Subject: [PATCH] Add rules for Kerberos.pm and AdjustUpgrade.pm

---
 src/test/perl/Makefile    | 4 ++++
 src/test/perl/meson.build | 2 ++
 2 files changed, 6 insertions(+)

diff --git a/src/test/perl/Makefile b/src/test/perl/Makefile
index 82ea63b08e..c02f18454e 100644
--- a/src/test/perl/Makefile
+++ b/src/test/perl/Makefile
@@ -22,16 +22,20 @@ install: all installdirs
 	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Test/Utils.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/Utils.pm'
 	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Test/SimpleTee.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/SimpleTee.pm'
 	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Test/RecursiveCopy.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/RecursiveCopy.pm'
+	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Test/Kerberos.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/Kerberos.pm'
 	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Test/Cluster.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/Cluster.pm'
 	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Test/BackgroundPsql.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/BackgroundPsql.pm'
+	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Test/AdjustUpgrade.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/AdjustUpgrade.pm'
 	$(INSTALL_DATA) $(srcdir)/PostgreSQL/Version.pm '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Version.pm'
 
 uninstall:
 	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/Utils.pm'
 	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/SimpleTee.pm'
 	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/RecursiveCopy.pm'
+	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/Kerberos.pm'
 	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/Cluster.pm'
 	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/BackgroundPsql.pm'
+	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Test/AdjustUpgrade.pm'
 	rm -f '$(DESTDIR)$(pgxsdir)/$(subdir)/PostgreSQL/Version.pm'
 
 endif
diff --git a/src/test/perl/meson.build b/src/test/perl/meson.build
index 4f0d928a6f..fc9cf971ea 100644
--- a/src/test/perl/meson.build
+++ b/src/test/perl/meson.build
@@ -10,6 +10,8 @@ install_data(
   'PostgreSQL/Test/Utils.pm',
   'PostgreSQL/Test/SimpleTee.pm',
   'PostgreSQL/Test/RecursiveCopy.pm',
+  'PostgreSQL/Test/Kerberos.pm',
   'PostgreSQL/Test/Cluster.pm',
   'PostgreSQL/Test/BackgroundPsql.pm',
+  'PostgreSQL/Test/AdjustUpgrade.pm',
   install_dir: dir_pgxs / 'src/test/perl/PostgreSQL/Test')
-- 
2.45.2

---

From: Michael Paquier <[email-masked]>
Date: Fri, 25 Oct 2024 10:58:13 +0900

> If people would prefer a backpatch, please let me know.

Hearing nothing, applied this one on HEAD for now.
--
Michael