Subject: Fix CheckIndexCompatible comment

From: Yugo NAGATA <[email-masked]>
Date: Fri, 4 Feb 2022 01:46:34 +0900

Hello,

I found a old parameter name 'heapRelation' in the comment
of CheckIndexCompatible. This parameter was removed by 5f173040.

Attached is a patch to remove it from the comment.

Regards,
Yugo Nagata

-- 
Yugo NAGATA <[email-masked]>
diff --git a/src/backend/commands/indexcmds.c b/src/backend/commands/indexcmds.c
index 560dcc87a2..95cb15cbb9 100644
--- a/src/backend/commands/indexcmds.c
+++ b/src/backend/commands/indexcmds.c
@@ -129,7 +129,6 @@ typedef struct ReindexErrorInfo
  *		prospective index definition, such that the existing index storage
  *		could become the storage of the new index, avoiding a rebuild.
  *
- * 'heapRelation': the relation the index would apply to.
  * 'accessMethodName': name of the AM to use.
  * 'attributeList': a list of IndexElem specifying columns and expressions
  *		to index on.

---

From: Fujii Masao <[email-masked]>
Date: Fri, 4 Feb 2022 09:08:22 +0900

> Attached is a patch to remove it from the comment.

Thanks for the report! I agree to remove the mention of parameter already dropped, from the comment. OTOH, I found CheckIndexCompatible() now has "oldId" parameter but there is no comment about it though there are comments about other parameters. Isn't it better to add the comment about "oldId"?

Regards,

-- 
Fujii Masao
Advanced Computing Technology Center
Research and Development Headquarters
NTT DATA CORPORATION

---

From: Nathan Bossart <[email-masked]>
Date: Thu, 3 Feb 2022 16:14:53 -0800

>> Attached is a patch to remove it from the comment.

It looks like this parameter was removed in 5f17304.
 
> Thanks for the report! I agree to remove the mention of parameter already dropped, from the comment. OTOH, I found CheckIndexCompatible() now has "oldId" parameter but there is no comment about it…

+1

-- 
Nathan Bossart
Amazon Web Services: https://aws.amazon.com

---

From: Yugo NAGATA <[email-masked]>
Date: Mon, 7 Feb 2022 19:14:18 +0900

Hello, Fujii-san,

On Fri, 4 Feb 2022 09:08:22 +0900

> Thanks for the report! I agree to remove the mention of parameter already dropped, from the comment. OTOH, I found CheckIndexCompatible() now has "oldId" parameter but there is no comment about it…

Agreed. I updated the patch to add a comment about 'oldId'.

Regards,
Yugo Nagata

-- 
Yugo NAGATA <[email-masked]>
diff --git a/src/backend/commands/indexcmds.c b/src/backend/commands/indexcmds.c
index 560dcc87a2..408ffc70f6 100644
--- a/src/backend/commands/indexcmds.c
+++ b/src/backend/commands/indexcmds.c
@@ -129,7 +129,7 @@ typedef struct ReindexErrorInfo
  *		prospective index definition, such that the existing index storage
  *		could become the storage of the new index, avoiding a rebuild.
  *
- * 'heapRelation': the relation the index would apply to.
+ * 'oldId': the existing index's relation OID
  * 'accessMethodName': name of the AM to use.
  * 'attributeList': a list of IndexElem specifying columns and expressions
  *		to index on.

---

From: Fujii Masao <[email-masked]>
Date: Fri, 18 Feb 2022 12:22:32 +0900

> Agreed. I updated the patch to add a comment about 'oldId'.

Thanks for updating the patch! I slightly modified the patch and pushed it.

Regards,