public inbox for [email protected]
help / color / mirror / Atom feedFrom: Peter Eisentraut <[email protected]>
To: David Steele <[email protected]>
To: [email protected]
To: Robert Haas <[email protected]>
Subject: Re: Rename backup_label to recovery_control
Date: Wed, 18 Oct 2023 09:07:38 +0200
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <[email protected]>
<CA+TgmoYnEdOsMM=4f4GFLhRMyiFBLT50OkFtgY8k20Psjv49zg@mail.gmail.com>
<[email protected]>
On 16.10.23 17:15, David Steele wrote:
>> I also do wonder with recovery_control is really a better name. Maybe
>> I just have backup_label too firmly stuck in my head, but is what that
>> file does really best described as recovery control? I'm not so sure
>> about that.
>
> The thing it does that describes it as "recovery control" in my view is
> that it contains the LSN where Postgres must start recovery (plus TLI,
> backup method, etc.). There is some other informational stuff in there,
> but the important fields are all about ensuring consistent recovery.
>
> At the end of the day the entire point of backup *is* recovery and users
> will interact with this file primarily in recovery scenarios.
Maybe "restore" is better than "recovery", since recovery also happens
separate from backups, but restoring is something you do with a backup
(and there is also restore_command etc.).
view thread (4+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected]
Subject: Re: Rename backup_label to recovery_control
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox