Subject: Possible typo in an error message

From: Kyotaro Horiguchi <[email-masked]>
Date: Fri, 10 Jul 2026 13:52:26 +0900 (JST)

Hello,

While translating this message, I noticed the following error text:

parse_jsontable.c:644:
> errdetail("PATH name was %s not found in nested columns list.",

Is this perhaps meant to be

PATH name %s was not found in nested columns list.

instead?

Also, I wasn't quite sure whether the uppercase "PATH" in messages
such as "PATH name" has any particular significance. For the
translation, I ended up treating it as the ordinary word "path", since
I couldn't tell whether it was intended to refer to the SQL keyword or
just the general concept.

I found another occurrence of the similar wording:

parse_jsontable.c:324:
>   errdetail("PATH name mismatch: expected %s but %s is given."

Regareds,

-- 
Kyotaro Horiguchi
NTT Open Source Software Center

---

From: Andreas Karlsson <[email-masked]>
Date: Fri, 10 Jul 2026 09:31:15 +0200

> PATH name %s was not found in nested columns list.

Agreed, or maybe:

"Path name %s not found in nested columns list."

 From what I can see both forms are used in our error messages.

> just the general concept.

Agreed, it does not look like it is a keyword so it should not be 
written in upper case.

>>    errdetail("PATH name mismatch: expected %s but %s is given."

That looks like it should be "Path name" too.

-- 
Andreas Karlsson
Percona

---

From: Daniel Gustafsson <[email-masked]>
Date: Fri, 10 Jul 2026 10:05:33 +0200

> On 10 Jul 2026, at 09:31, Andreas Karlsson <[email-masked]> wrote:
> 

I would favor "was not found" since the JSON_TABLE support has a similar
wording for missing PLAN clauses: "PLAN clause for nested path %s was not
found".  Consistency within a feature is good.

> Agreed, it does not look like it is a keyword so it should not be written in upper case.

I think it does refer to the PATH keyword in a NESTED PATH clause.  See below
for an example query from our regression tests:

SELECT * FROM JSON_TABLE(
       jsonb '[]', '$' AS path1
       COLUMNS (
               NESTED PATH '$' COLUMNS (
                       foo int PATH '$'
               )
       )
       PLAN DEFAULT (UNION)
) jt;

--
Daniel Gustafsson