Subject: Re: [PATCH] Fix ARM64/MSVC atomic memory ordering issues on Win11 by adding explicit DMB ?barriers

From: Tom Lane <[email-masked]>
Date: Sun, 04 Jan 2026 15:13:15 -0500

"Greg Burd" <[email-masked]> writes:
> What this patch does is get "unicorn" off the dead list, which would be nice.

Indeed ... I'm getting pretty tired of seeing unicorn cluttering
the BF failures list.  Is there a reason we're still holding off
committing, other than it being holiday season?

			regards, tom lane

---

From: Nathan Bossart <[email-masked]>
Date: Sun, 4 Jan 2026 14:21:44 -0600

> committing, other than it being holiday season?

Nope, I was planning to commit it in a few days when I am back.

-- 
nathan

---

From: "Greg Burd" <[email-masked]>
Date: Mon, 05 Jan 2026 07:42:07 -0500

>> committing, other than it being holiday season?

Tom, I'd turned off the "cron" equivalent on unicorn (or so I hope, Windows is... odd) the morning you sent this to reduce noise.  Apologies for that.  As soon as Nathan commits that patch I'll re-start it.  I'm also still committed to finishing up the other pieces and docs so that it's not half-done.

> Nope, I was planning to commit it in a few days when I am back.

Nathan, thanks!  Let's coordinate when you're back online. :)

best,

-greg

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 7 Jan 2026 13:46:36 -0600

> Nope, I was planning to commit it in a few days when I am back.

Committed.

-- 
nathan