Subject: pg_restore: TAP test case typo(wrong word) for an error hint in 001_basic.pl

From: Mahendra Singh Thalor <[email-masked]>
Date: Sun, 15 Mar 2026 22:59:53 +0530

Hi,

While doing some changes, I found a typo error(wrong word) in 001_basic.pl
file.

In 31a8b77a9244a0883e1968adc, we added some test cases for pg_dump,
pg_restore and pg_dumpall.
In one error case, we added  'pg_dump' name instead of 'pg_rsetore'.

diff --git a/src/bin/pg_dump/t/001_basic.pl b/src/bin/pg_dump/t/001_basic.pl
index 9f12ca6c51d..ff1d422292e 100644
--- a/src/bin/pg_dump/t/001_basic.pl
+++ b/src/bin/pg_dump/t/001_basic.pl
@@ -144,7 +144,7 @@ command_fails_like(
 command_fails_like(
        [ 'pg_restore', '-f -', '-F', 'garbage' ],
        qr/\Qpg_restore: error: unrecognized archive format "garbage";\E/,
-       'pg_dump: unrecognized archive format');
+       'pg_restore: unrecognized archive format');

Here, I am attaching a patch to fix this.This patch can be applied till
PG14.

I think we should back-patch till PG14. Please review this.

-- 
Thanks and Regards
Mahendra Singh Thalor
EnterpriseDB: http://www.enterprisedb.com
From e2ac7e08da8be18dbe131242a0b8c13e999b0d43 Mon Sep 17 00:00:00 2001
From: Mahendra Singh Thalor <[email-masked]>
Date: Sun, 15 Mar 2026 22:55:59 +0530
Subject: [PATCH] pg_restore TAP test fix wrong word

While doing some changes, I found a typo error(wrong word)
in 001_basic.pl file.

In 31a8b77a9244a0883e1968adc, we added some test cases for pg_dump,
pg_restore and pg_dumpall. In one error case, we added the 'pg_dump'
name instead of 'pg_rsetore'.

back-patch till PG14
---
 src/bin/pg_dump/t/001_basic.pl | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/bin/pg_dump/t/001_basic.pl b/src/bin/pg_dump/t/001_basic.pl
index 2f5eb48e7b8..9305c46f4af 100644
--- a/src/bin/pg_dump/t/001_basic.pl
+++ b/src/bin/pg_dump/t/001_basic.pl
@@ -199,7 +199,7 @@ command_fails_like(
 command_fails_like(
 	[ 'pg_restore', '-f -', '-F', 'garbage' ],
 	qr/\Qpg_restore: error: unrecognized archive format "garbage";\E/,
-	'pg_dump: unrecognized archive format');
+	'pg_restore: unrecognized archive format');
 
 command_fails_like(
 	[ 'pg_dump', '--on-conflict-do-nothing' ],
-- 
2.52.0

---

From: Michael Paquier <[email-masked]>
Date: Mon, 16 Mar 2026 08:29:04 +0900

> I think we should back-patch till PG14. Please review this.

Thanks, grabbed this one for later.  I am not sure if it is worth
bothering about the back-branches.  If somebody feels otherwise,
please feel free to overwrite me and I will adapt.
--
Michael

---

From: Mahendra Singh Thalor <[email-masked]>
Date: Fri, 20 Mar 2026 01:33:00 +0530

Thanks Michael for the review.

Please can you push this change into master?

Thanks and Regards
Mahendra Singh Thalor

---

From: Nathan Bossart <[email-masked]>
Date: Thu, 19 Mar 2026 15:07:05 -0500

> Please can you push this change into master?

I took care of this in commit ec80215c03.

-- 
nathan

---

From: Mahendra Singh Thalor <[email-masked]>
Date: Fri, 20 Mar 2026 02:00:33 +0530

> I took care of this in commit ec80215c03.

Thanks Nathan. I only saw the commit message. Apologize.