Subject: DOCS - System Applications 'datadir' parameter

From: Peter Smith <[email-masked]>
Date: Wed, 18 Feb 2026 18:27:50 +1100

Hi.

In most places, each of the Server Application documentation pages [1]
refers to the directory where the database cluster lives as 'datadir'.
However, a few places called it 'directory' instead.

This patch changes the outliers also to 'datadir', making everything
more consistent.

e.g.
initdb: change in Synopsis and Options
pg_checksums: change in Options
pg_controldata: OK
pg_createsubscriber: change in Options
pg_ctl: OK
pg_resetwal: OK
pg_rewind: change in Synopsis and Options
pg_upgrade: Leave as-is (e.g. configdir may not be the same as datadir)
postgres: OK

PSA patch for details.

======
[1] https://www.postgresql.org/docs/devel/reference-server.html

Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Peter Smith <[email-masked]>
Date: Fri, 20 Mar 2026 14:43:56 +1100

Ping. This thread has been idle for 1 month.

Is there anything else I can do to move it forwards?

======
Kind Regards,
Peter Smith.
Fujitsu Australia.

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 23 Mar 2026 12:14:19 -0400

> This patch changes the outliers also to 'datadir', making everything

Good catch.  These clearly need to be datadirs and not just any
directory.  Patch applied to master, thanks.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Do not let urgent matters crowd out time for investment in the future.

---

From: Peter Smith <[email-masked]>
Date: Tue, 24 Mar 2026 09:38:28 +1100

On Tue, Mar 24, 2026 at 3:14 AM Bruce Momjian <[email-masked]> wrote:
...
> directory.  Patch applied to master, thanks.

Thanks for pushing!

======
Kind Regards,
Peter Smith.
Fujitsu Australia