Subject: Minor refactor of the code in ExecScanExtended()

From: "cca5507" <[email-masked]>
Date: Fri, 7 Nov 2025 22:00:15 +0800

Hi,

The current code:

      if (!qual &amp;&amp; !projInfo)
      {
            ResetExprContext(econtext);
            return ExecScanFetch(node, epqstate, accessMtd, recheckMtd);
      }

      ResetExprContext(econtext);

The following format might be simpler:

      ResetExprContext(econtext);

      if (!qual &amp;&amp; !projInfo)
            return ExecScanFetch(node, epqstate, accessMtd, recheckMtd);

Attach a patch to do this.

--
Regards,
ChangAo Chen

---

From: Henson Choi <[email-masked]>
Date: Wed, 25 Mar 2026 10:53:55 +0900

Hi hackers,

2026년 1월 19일 (월) PM 1:51, Aditya Gollamudi <[email-masked]>님이 작성:

> On Sun, Jan 18, 2026 at 7:31 PM cca5507 <[email-masked]> wrote:
>
>> Hi,
>>
>> The current code:
>>
>> if (!qual && !projInfo)
>> {
>> if (!qual && !projInfo)
> +1, seems like a simple refactor.
> Tests are passing locally for me!
>
> - Adi Gollamudi
>

+1, agreed.

The refactored version is cleaner and easier to read by moving
ResetExprContext() before the early return,
eliminating the duplicated logic.

Best regards,
Henson

---

From: Michael Paquier <[email-masked]>
Date: Wed, 25 Mar 2026 10:58:23 +0900

> Attach a patch to do this.

There is no benefit in this change: the current code is fine.
--
Michael