Subject: Re: Remove unused at_sharedrel from autovac_table

From: Michael Paquier <[email-masked]>
Date: Wed, 25 Mar 2026 17:02:19 +0900

On Wed, Mar 25, 2026 at 04:57:34PM +0900, Yugo Nagata wrote:
> I've attached a trivial patch that removes at_sharedrel from autovac_table.
> This field was introduced in commit 15739393e4 to handle skipping of
> shared relations in autovacuum, but it has been unused since commit
> 38f7831d70.

Indeed, yes.  There is no need for it.
--
Michael

---

From: Michael Paquier <[email-masked]>
Date: Thu, 26 Mar 2026 08:09:34 +0900

On Wed, Mar 25, 2026 at 06:27:38PM +0100, Alvaro Herrera wrote:
> Pushed (before seeing this email of yours).

No worries, I had this one saved locally in my stack for trivial
changes.  I'll just rebase.  Thanks for the override.
--
Michael